Messages recommandés

bonsoir

j'ai le même problème, un répertoire mycin se crée lorsque je lance le script.

le répertoire que j'ai placé par FTP sur la xbox est celui qui se crée lors de la décompression du fichier zip de la version 8.6.1, il ne contient pas d'accent.

voila voila

merci

Lien vers message
Partager sur d'autres sites
  • Réponses 607
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Bon, je ne reproduis pas le problème chez moi.

Ca doit venir de la version d'Xbmc (elle n'est pas toute récente chez moi). Ce serait donc la fonction de récupération du répertoire courant qui ne renverrait plus le même résultat.

Quelle version utilisez-vous lorsque vous rencontrez ce problème?

Pour résoudre le problème temporairement, je pense que vous pouvez prendre les fichiers du répertoire mycin et les copier dans le répertoire mycine, en écrasant les anciens.

Modifié par Trucide
Lien vers message
Partager sur d'autres sites

Bon, j'ai vérifié en installant la version PC d'XBMC et c'est bien ça, la fonction os.getcwd() a changé.

Il ne me reste plus qu'à faire une version compatible pour les anciennes et nouvelles moutures d'XBMC.

Je m'y penche dès que possible.

A+

Trucide

Lien vers message
Partager sur d'autres sites

Salut,

Alors moi je l'ai testé hier un long moment, et je n'ai AUCUN BUG!

Ni à l'utilisation ni à la mise à jour... tout est bon en ce qui concerne le visionnage des Bandes annonces :D

J'utilise l'avant dernière version de XBMC!

Par contre lol ... car malheureusement ce mot revient souvent...

Cet été je suis passé à la HD aussi pour mon PROJO, et du coup ma xBox ne tourne plus que en HD lol

C'est le top, mais, où trouver un ou des skins sympa pour MyCiné en HD 720p.

Car moi il s'exécute en petit en haut ds le coin gauche :(

Puis j'ai un bug aussi qd je le lance en BasseDef, je ne sais pas si c'est lié ... mais qd les POPup s'ouvrent pour choisir la BA puis après la résolution, je ne voie pas ce que je choisi.

Je n'ai que le bruit, la ligne ne se met pas en surbrillance et c'est pas pratique juste avec le bruitage lol

Enfin, la question BONUX ... qd je lis les BA en HD, souvent ça rame assé sévère :(

Alors que chez Apple, c'est de la HD aussi et c'est fluide ?

Pkoi ?

Merci Trucide

Lien vers message
Partager sur d'autres sites
Salut,

Alors moi je l'ai testé hier un long moment, et je n'ai AUCUN BUG!

Ça, j'aime!!! :)

Cet été je suis passé à la HD aussi pour mon PROJO, et du coup ma xBox ne tourne plus que en HD lol

C'est le top, mais, où trouver un ou des skins sympa pour MyCiné en HD 720p.

Car moi il s'exécute en petit en haut ds le coin gauche :(

Je suis surpris car j'ai fait un fichier de config qui place comme il faut tous les élément pour le 720p. Senpai avait testé.

D'ailleurs, tu avais posté en disant que tu allais tester ici

Comme je n'ai pas la chance :( d'avoir un écran HD, je ne peux tester qu'avec l'émulateur. Et ça passe bien en 720p, mais pas en 1080i.

T'es sûr que tu n'es pas en 1080i?

Puis j'ai un bug aussi qd je le lance en BasseDef, je ne sais pas si c'est lié ... mais qd les POPup s'ouvrent pour choisir la BA puis après la résolution, je ne voie pas ce que je choisi.

Je n'ai que le bruit, la ligne ne se met pas en surbrillance et c'est pas pratique juste avec le bruitage lol

C'est quoi la basseDef pour toi?

Enfin, la question BONUX ... qd je lis les BA en HD, souvent ça rame assé sévère :(

Alors que chez Apple, c'est de la HD aussi et c'est fluide ?

Pkoi ?

Ah ça, c'est un problème insoluble. Si parfois les BA HD rament, c'est que notre Bobox adorée s'essouffle un peu! :(

La décompression est trop coûteuse en CPU et on aperçoit les limites de la bête! C'est pour ça qu'on peut choisir entre BA classique et BA HD.

Mais c'est vrai que j'ai remarqué que les Vidéos HD d'Apple sont magnifiques. Et elles passent très bien.

Je crois qu'elles sont codées en x264, codec très performant mais pourtant assez gourmand au niveau de la décompression.

Alors ça peut venir de la taille des vidéos: plus la résolution est élevée, plus la décompression est consommatrice de CPU.

Donc, la solution: si ça rame, visionner la BA en basse définition! :(

Lien vers message
Partager sur d'autres sites

Alors, j'ai approfondi les tests et :

- TOUT marche nickel, mm la salle de cinéma, le quiz tout ça ... rien à recoder la dessus!

- Par contre j'ai bien un bug dans les menus. Genre le menu de la fiche elle mm, je voie bien qd je selection la BA ou les acteurs ou autre .... mais qd je clique sur BandeAnnonces et que la petitre fenetre s'ouvre ... je n'ai que le son!

Je ne voi pas le texte se surligner en blanc pour que je voi ce que je selectionne et lance :(

- Moi que je suis que je suis en "BasseDef" c'est que je suis en résolution classique, je lance le "MyCine.py" normal, qui me met un affichage tout flou genre 800x600 comme avant alors que je suis normalement en 720p ds le menu principal.

Et si je lance ton exécutable "MyCine720p.py" il m'a une seule fois affiché le MyCiné en petit en haut a gauche et la il ne se lance mm plus lol

Donc pas de réelle gestion de la HD ... s'il faut te faire un SKIN pour que toi tu gère le codage, je suis ton homme, tiens moi au jus.

(PS : A l'époque où je devais tester comme je l'avais écris je n'ai par la suite pas pu et c'est pour ça que je n'avais pas posté de réponse après)

- Enfin, pour le LAG en relisant les posts précédent j'ai vu que tu parlais de monter le cache et effectivement le LAG arrive plus tard ... mais il fini qd mm par arriver lol

Du coup je soupçonne une lenteur chez Allociné ? vue que chez Apple ça ne le fais pas! Et la je ne pense pas que l'encodage soit en cause vue que la console lit tres bien les films en HD 720 et 1080p, je viens de tester :D

Merci

@tt

Modifié par darknior
Lien vers message
Partager sur d'autres sites

Bouuuuuuu .... il n'y a plus personne sur ce topic ?

C'est par ce que c'est la rentrée ... ? ... plus le tps de nous faire un petit coucou pour nous dire au moins si les BUGs de curseur dans les menus seront réglés ou pas ?

Merci

Lien vers message
Partager sur d'autres sites
  • 3 weeks later...

Salut tout le monde.

Il y a eu des changements avec Python sur Xbmc. La gestion des interfaces, des chemins, tout cela a évolué et nombre de Scripts sont affectés. (j'en ai déja parlé dans le sujet sur F2xtv et Temhil en a fait de même dans le sujet sur Mediastream.

Je compte bien en lister une partie et tenter de rendre visible les solution à apporter, demander le concours de quelques développeurs pour en réparer au moins ceux auxquels beaucoup de gens ont attachés. Seulement je n'ai pas le temps actuellement, je suis vraiment overbooké.

A suivre donc et toute aide est bienvenue.

Lien vers message
Partager sur d'autres sites
  • 3 weeks later...

Salut tout le monde,

désolé de ne plus répondre, mais apparemment, je ne reçois plus les notifications de message sur ce sujet! :(

En plus, j'ai été un peu occupé ces temps-ci.

Pour résoudre les problèmes d'évolution de Python, le mieux il me semble et que je fasse un zip avec la dernière version qui fonctionne, puisque les dernières versions d'XBMC empêchent le script de se mettre à jour.

Je fais ça très vite.

A+

Trucide

Lien vers message
Partager sur d'autres sites
Salut tout le monde,

désolé de ne plus répondre, mais apparemment, je ne reçois plus les notifications de message sur ce sujet! :(

En plus, j'ai été un peu occupé ces temps-ci.

Pour résoudre les problèmes d'évolution de Python, le mieux il me semble et que je fasse un zip avec la dernière version qui fonctionne, puisque les dernières versions d'XBMC empêchent le script de se mettre à jour.

Je fais ça très vite.

A+

Trucide

Salut Trucide,

En fait je sais pas si tu as reçu le mail que je t'ai envoyé hier (seb012007), mais je viens de faire les corrections nécessaires pour rendre le script compatible toute version de xbmc et tout os, par contre ça fait sauter les mises à jour en effet. (et j'ai dû faire un petit quelque chose car il manquait la lib PIL sur les versions linux de xbmc)

Veux-tu que je te le renvoie? (je ne l'ai pas rendu public encore)

EDIT : Désolé pour ce message, Trucide avait bien reçu mon mail, c'est moi qui n'avait pas reçu sa réponse!

Modifié par SeBaB
Lien vers message
Partager sur d'autres sites

Hello tout le monde,

Je n'ai plus beaucoup le temps de passer ici et croyez bien que je le regrette.

Cela fait déja quelques jours que Seb à fait uUne version provisoire de Mycine qui fonctionne en attendant la version définitive de Trucide.

Vous pouvez auss l'importer dans Xbmc, toutes plateformes confondues avec L'installateur passion

Modifié par shaitan
Lien vers message
Partager sur d'autres sites

Salut,

En tout cas, dans la future mise à jour, essayais de corriger le BUG qui fait que on ne se voie pas bouger dans les menus de choix des BA car que ce soit en HD ou pas ça me fait pareil :(

Je suis obligé de compter pour savoir quel trailer je vais matter lol

Merci d'avance

Lien vers message
Partager sur d'autres sites
  • 2 weeks later...
  • 2 weeks later...

salut

moi j'ai un souci avec mycine, je viens d'installer le nouveau xbmc atlantis, et mon mycine ne fonctionne plus, j'ai un message test resolution et connection et plus rien. pe pa faire de mise a jour apres j'ai un message de pb de connection alors que j'ai la meteo et je pe visionner des trailers de apple movie.

en fait si il demarre, j'ai juste le nom des menu et rien d'autre un peu d' aide svp.

a plus 'j'attend vos reponse.

de plus je pe pa mettre a jour mon xbmc par le tech 3 updater.

Lien vers message
Partager sur d'autres sites

Salut littlesinse

Quelle version de Mycine utilise tu? La version officielle ou bien la version provisoire mentionnée plus haut?

Peux-tu aussi fournir des logs pour les developpeurs?

Merci d'avance.

Lien vers message
Partager sur d'autres sites
bon j'ai pri la version non officiel et ca fonctionne donc c cool, je l'ai pri sur xbmc passion.

Oui en effet du aux dernière modification dans XBMC, la version officiel de MyCine ne fonctionne plus. Leur développeurs doivent avoir déjà pas mal a faire, aussi Seb sur passion-xbmc a corriger rapidement le probleme et sorti une version non officielle en attendant que ce soit corrigé officiellement. Mais attention cette version non officielle ne supporte pas la mise a jour auto, donc il vous faudra survieller ce fil et remplacer la version non officielle par la version offcielle manuellement.

FYI la version non offcielle est aussi disponible est installable via le script Installeur Passion XBMC

Lien vers message
Partager sur d'autres sites
  • 3 months later...

Salut à tous,

voici (enfin!!!) la nouvelle version du script MyCiné: :ice:

v8.6.9 - 14/03/09

- Réparation de la mise à jour automatique

- Réparation des recherches

- Réparation de la fiche film

Il faut utiliser le nouveau fichier ce lancement: default.py. Copiez le dans le répertoire de MyCiné.

Donc, attention de ne plus lancer mycine.py comme au auparavant.

Maintenant, sélectionner le répertoire de MyCiné suffit pour lancer le script.

Voilà, n'hésitez pas à poster toutes les anomalies que vous détectez!

A+

Trucide.

Modifié par Trucide
Lien vers message
Partager sur d'autres sites
Salut à tous,

voici (enfin!!!) la nouvelle version du script MyCiné: :ice:

v8.6.9 - 14/03/09

- Réparation de la mise à jour automatique

- Réparation des recherches

- Réparation de la fiche film

Il faut utiliser le nouveau fichier ce lancement: default.py. Copiez le dans le répertoire de MyCiné.

Donc, attention de ne plus lancer mycine.py comme au auparavant.

Maintenant, sélectionner le répertoire de MyCiné suffit pour lancer le script.

Voilà, n'hésitez pas à poster toutes les anomalies que vous détectez!

A+

Trucide.

Salut Trucide,

Apres avoir eu qeulques pbs pour metrre a jour le script (je partais d'une 8.6.6 et ca posait pb), j'ai finalemnent reussi a mettre a jour MyCine, par contre on a un pb d'API xbmc avec les derniere versions de XBMC, voici l'erreur:

15:11:43 T:14100 M:980942848  NOTICE: -->Python Interpreter Initialized<--15:11:43 T:14100 M:980942848  NOTICE: 15:12:12 T:14100 M:965554176   ERROR: Exception in python script's onAction15:12:12 T:14100 M:965554176  NOTICE: Traceback (most recent call last):15:12:12 T:14100 M:965554176  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 779, in onAction15:12:12 T:14100 M:965566464  NOTICE: 15:12:12 T:14100 M:965566464  NOTICE: if action == ACTION_PREVIOUS_MENU:15:12:12 T:14100 M:965566464  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 585, in onControl15:12:12 T:14100 M:965681152  NOTICE: 15:12:12 T:14100 M:965681152  NOTICE: movieList = MovieList(retrievers = [retr1,retr2,retr3])15:12:12 T:14100 M:965681152  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 848, in __init__15:12:13 T:14100 M:965664768  NOTICE: 15:12:13 T:14100 M:965664768  NOTICE: self.getMovies()15:12:13 T:14100 M:965664768  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 878, in getMovies15:12:13 T:14100 M:965664768  NOTICE: 15:12:13 T:14100 M:965664768  NOTICE: self.__list[self.__hIndex].addItem(item)15:12:13 T:14100 M:965664768  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCineUtils.py", line 58, in addItem15:12:13 T:14100 M:965660672  NOTICE: 15:12:13 T:14100 M:965656576  NOTICE: item.createControls(self.__w,self.__width)15:12:13 T:14100 M:965656576  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCineUtils.py", line 159, in createControls15:12:13 T:14100 M:965652480  NOTICE: 15:12:13 T:14100 M:965652480  NOTICE: sc = self.__textCtrl.getSpinControl()15:12:13 T:14100 M:965652480  NOTICE: AttributeError15:12:13 T:14100 M:965652480  NOTICE: :15:12:13 T:14100 M:965652480  NOTICE: 'xbmcgui.ControlTextBox' object has no attribute 'getSpinControl'15:12:13 T:14100 M:965652480  NOTICE: 15:12:19 T:14100 M:963411968   ERROR: Exception in python script's onAction15:12:19 T:14100 M:963411968  NOTICE: Traceback (most recent call last):15:12:19 T:14100 M:963411968  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 779, in onAction15:12:19 T:14100 M:963911680  NOTICE: 15:12:19 T:14100 M:963911680  NOTICE: if action == ACTION_PREVIOUS_MENU:15:12:19 T:14100 M:963911680  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 585, in onControl15:12:19 T:14100 M:963903488  NOTICE: 15:12:19 T:14100 M:963903488  NOTICE: movieList = MovieList(retrievers = [retr1,retr2,retr3])15:12:19 T:14100 M:963903488  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 848, in __init__15:12:19 T:14100 M:963883008  NOTICE: 15:12:19 T:14100 M:963883008  NOTICE: self.getMovies()15:12:19 T:14100 M:963883008  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCine85.py", line 878, in getMovies15:12:20 T:14100 M:963870720  NOTICE: 15:12:20 T:14100 M:963870720  NOTICE: self.__list[self.__hIndex].addItem(item)15:12:20 T:14100 M:963870720  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCineUtils.py", line 58, in addItem15:12:20 T:14100 M:963829760  NOTICE: 15:12:20 T:14100 M:963829760  NOTICE: item.createControls(self.__w,self.__width)15:12:20 T:14100 M:963825664  NOTICE:   File "D:\[Hardware]\Xbox\Program Files\XBMC\scripts\[Test]\MyCine\MyCineUtils.py", line 159, in createControls15:12:20 T:14100 M:963821568  NOTICE: 15:12:20 T:14100 M:963821568  NOTICE: sc = self.__textCtrl.getSpinControl()15:12:20 T:14100 M:963821568  NOTICE: AttributeError15:12:20 T:14100 M:963821568  NOTICE: :15:12:20 T:14100 M:963821568  NOTICE: 'xbmcgui.ControlTextBox' object has no attribute 'getSpinControl'15:12:20 T:14100 M:963821568  NOTICE: 15:12:20 T:14100 M:950706176   ERROR: GL: Error making context current

La raison est simple, dans les dernieres versions de XBMC, la classe ControlTextBox n 'a plus la methode getSpinControl()je ne suis pas sur pour quelle raison on utilise cette methode (je ne l'ai jamis utilise moi meme).

Donc sur une version d'XBMC recente Mycine ne marche pas a cause de cela :unsure: desole pour la muvaise nouvelle :rolleyes:

Lien vers message
Partager sur d'autres sites
  • 1 month later...

Hello,

une nouvelle version de MyCiné est en ligne:

v8.6.10 - 25/04/09

  • Réparation de sorties au cinéma

Voilà, n'oubliez pas de me remonter les problèmes, cela permet de réparer au plus vite le script.

A+

Trucide

Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

Annonces