hyunkel

[résolu] Nand Aléatoire...

Messages recommandés

Bonsoir à tous, je me suis décidé de sortir la console du placard et de la passé en Jtag ^^

Cependant je tombe sur un os presque à la 1ère partie des opérations : le dump nand...

Alors pour le dump je possède :

- Falcon 14,2A, Nand 16mo, Fw: 7371, BC: 5766

- Un cable LPT

- 5 Résistances 240 ohm

- 1 diode 1n4148

Donc tout le montage est bien en place, les connexions également (vérifié 2 fois au multimètre + tout bien nettoyer).

La longueur de mon câble est d'environ 20 cm, et j'utilise NandPro 2.0e mais j'ai également tester avec la d et la b.

J'ai mon LPT à l'address 0378.

et bien mon FlashConfig: 01198010

Les nand facon étant de 16 Mo, j'ai également bien Starting Block:0x000000, Ending Block0x0003FF

Je lance donc :

nandpro lpt: -r16 nand.bin

et patiente 45min...

Résultat: Dump bien passé, aucune erreur style 250 ou autre.

Le problème :

J'ai dumper plusieurs fois ma nand sans erreur (j'en suis à 16) mais impossible d'avoir 2 fichiers identique !

360 Flash Tool refuse également de m'en ouvrir environ 50% (probablement à cause des premiers block corrompu).

Même s'il est conseillé de dumper en mode basique (SPP), dans le doute j'ai également tester en EPP et ECP = idem.

Je ne sais plus trop quoi faire, quelqu'un aurai une idée ?

Merci d'avance cordialement

Edit du titre: Sujet Résolu

Modifié par hyunkel

Partager ce message


Lien vers message
Partager sur d'autres sites

j'ai exactement le même problème :( impossible de faire deux dump identique, est impossible de lire les ficher dumpé avec flash tool ( il plante et se ferme tous seul) sauf un seul dump qui j'ai pu lire mais qui n'est pas identique avec les autre ( y'a énormément de différence avec la commande FC)...

y'a t-il Une solution a part les module USb?

Modifié par kirahicham

Partager ce message


Lien vers message
Partager sur d'autres sites

Vous avez essayer de faire un md5 sur 2 dump? mstMD520e.exe

Au début je faisais des fc pour comparer 2 fichier, ça c'est beaucoup plus simple.

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut

Essaye cette solution,elle Fonctionne a tout les coups ,elle est plus fiable et fonctionne très bien elle va te permettre de recupérer un dump de tes 2 premiers mo

On commence par récuperé la partie de la nand qui nous intéresse, on va récupérer les 2 premier méga, et le faire plusieurs fois pour être sur en vérifiant qu'ils sont identique ( utiliser par exemple la commande fc Nand2mo1.bin Nand2mo2.bin pour comparer les 2 dump nommer Nand2mo1.bin et nand2mo2.bin ) :

nandpro lpt: -r2 Nand2mo.bin

Maintenant que vous avez récupérer les 2 premier méga de votre nand et que vous avez vérifié qu'ils sont identiques, vous pouvez directement flasher le Xell dans votre console :

recupérer le fichier de Xell correspondant a votre consolle ( pour moi une xenon avec CB1921 donc)

(Utilisez le Xell correspondant a votre console , xenon, xenon cb1921, falcon, ou jasper, jasper256/512)

nandpro lpt: -w16 xenon_1921hack.bin

Ensuite suit ce tuto:

http://gueux-forum.net/index.php?showtopic=231504

Avec un logiciel, vérifier que les backup nand 16Mo réalisé sous Debian sont identiques ( moi j'utilise md5mst qui permet de simplement glisser le fichier dessus pour avoir son MD5).

s'ils sont tous identique on peut continuer,

Avec un editeur hexa ( j'ai utilisé "free Hex Editor Neo"), réinjecter les 2mo de votre "nand2Mo.bin" dans le "backup.bin", vous avez un backup légitime et original.

Sauvez le sous par exemple sous NAND.bin[/u]

On se retrouve donc avec un nand 100% dorigine construit avec les 2mo d'origine réinjecté dans le dump de 16mo fait sous Debian ( et ayant donc les 1.5premier Mo modifié par xell)

Bonne chance

Modifié par COEURDEROSES

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjours, et tout d'abord merci des réponses et de votre attention...

Vous avez essayer de faire un md5 sur 2 dump? mstMD520e.exe

Au début je faisais des fc pour comparer 2 fichier, ça c'est beaucoup plus simple.

Merci mais j'ai déjà un lecteur md5, qui confirme les différences...

Salut

etc...

Bonne chance

Je connais effectivement cette technique, il me parait évident que je n'aurai pas posté sinon (quoique avec les boulets qui ne lisent rien on ne sais jamais...), cependant ceci ne réssoud rien étant donné que comme je l'ai dit je n'arrive pas à avoir 2 dump identique... que ca soit en 16 ou en 2mo...

Cordialement

Modifié par hyunkel

Partager ce message


Lien vers message
Partager sur d'autres sites

Ben après il reste pas 5000 solution, mauvais câble, mauvaise soudure, essayer 5 résistances 100 Ohm, , jouer avec les résistances en les supprimant...

Regarde

Partager ce message


Lien vers message
Partager sur d'autres sites
Ben après il reste pas 5000 solution, mauvais câble, mauvaise soudure, essayer 5 résistances 100 Ohm, , jouer avec les résistances en les supprimant...

Regarde

+1 et ton cable lpt doit faire max 25cm sinon nombreuses erreurs de lecture

Partager ce message


Lien vers message
Partager sur d'autres sites

Ca dépend aussi de votre PC des fois, le mieux c'est de se payer ou de fabriquer un module usb pour bannir le lpt qui est pas vraiment fiable.

Partager ce message


Lien vers message
Partager sur d'autres sites

Tout a fait d'accord avec Lechuck Norris, le lpt fait chi.. , j'ai fait 3 console avec et que tu temps perdu pour les dumps. Depuis j'ai mon module usb, j'ai du faire au moin 50 jtag et j,ai eu de probleme de dump. Il faut aussi vérifier que ta pate a souder est non conductive car meme apres avoir néttoyé les pate conductives peuvent faire des problemes.

Partager ce message


Lien vers message
Partager sur d'autres sites
Ben après il reste pas 5000 solution, mauvais câble, mauvaise soudure, essayer 5 résistances 100 Ohm, , jouer avec les résistances en les supprimant...

Regarde

Comme je le disais précédemment j'ai vérifié à 2 reprises mon câble et mon montage, ce n'es pas ceci qui sont en cause...

+1 et ton cable lpt doit faire max 25cm sinon nombreuses erreurs de lecture

J'avais également signalé que mon câble était de 20 cm ^^

Ca dépend aussi de votre PC des fois, le mieux c'est de se payer ou de fabriquer un module usb pour bannir le lpt qui est pas vraiment fiable.

+1...

J'avais commencer dès ce matin à monté un autre pc pour testé...

Je viens de terminer 3 dump identique du 1er coup... = Sujet Résolu

Pour conclure c'était bien le pc qui était en cause !, Le port parallèle de celui-ci fonctionne pourtant parfaitement bien avec une imprimante...

J'en déduit donc que nandpro n'es pas compatible avec toutes les cartes mères...

A mon sens il serai bon de créer une page la dessus en référençant les CM incompable... en loccurance celle qui ne fonctionne pas dans mon cas est une P4S800, avec l'autre aucun problème, ni même d'erreur de lecture...

Merci à tous d'avoir participé à ce sujet, et d'avoir essayer de m'aider

Cordialement

Modifié par hyunkel

Partager ce message


Lien vers message
Partager sur d'autres sites

merci hyunkel pour le retour, je pense aussi que mon problème viens de mon PC (car une dizaine de dump même les 2mo non identique), je vais essayer sur un autre PC pour voir....

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant