Raj0r

Full Screen Mode

Messages recommandés

Salut tout le monde

Je n'arrive pas a avoir mon divx en plein ecran avec mplayer quand je mets full screen le divx reste en normal size avec la bande noir autour

Comment faire pour avoir une plein image ?

Merci d'avance

hello,

t'es bien tombé, t'es pile sur le topic qui te donne le tuto pour le faire :ok:

Il te faut VLC.

++

Partager ce message


Lien vers message
Partager sur d'autres sites

C'est peut-être dû à YDL...il me semble que ça me faisait ça aussi.

Par contre depuis que je suis sous Ubuntu j'ai du plein écran avec Mplayer tout comme VLC sans avoir à faire la moindre manip.

Partager ce message


Lien vers message
Partager sur d'autres sites
C'est peut-être dû à YDL...il me semble que ça me faisait ça aussi.

Par contre depuis que je suis sous Ubuntu j'ai du plein écran avec Mplayer tout comme VLC sans avoir à faire la moindre manip.

hum c'est bon a savoir ca :)

Sous YDL j'ai aussi des bandes noires.

Et est ce que les H264 et autres HD tournent bien sous Ubuntu?

++

Partager ce message


Lien vers message
Partager sur d'autres sites

Donc si je comprend bien il faut mplayer et vlc ?

Modifié par Squarex

Partager ce message


Lien vers message
Partager sur d'autres sites

Aîe...c'est la question qui tue :P

Ben non en fait, ça marche mais ça rame un peu sous VLC...le résultat est meilleur sous Mplayer mais y'a une désynchro image/son au bout de quelques minutes crying .

N'étant pas un pro Linux, je ne sais pas quoi faire pour alléger le système, histoire d'aider un peu...

Je crois qu'il va encore falloir attendre une nouvelle version apportant quelques améliorations ou alors un accès au RSX (si Sony se décide...ce serait vraiment, et de loin, la meilleure solution).

Partager ce message


Lien vers message
Partager sur d'autres sites
Donc si je comprend bien il faut mplayer et vlc ?

Ca dépend, tu tournes sous quoi ? YDL, Ubuntu, autre...?

Sinon, peux importe le système, y'a toujours 2 façons de l'installer, soit en mode "Terminal" (lignes de commande), soit par l'interface graphique "Ajouter/Enlever" (ou quelque chose dans le genre, ça dépend de la distrib).

Modifié par pat18

Partager ce message


Lien vers message
Partager sur d'autres sites

Bon et bien comme j'ai réinstallé Ubuntu récement, j'ai voulu refaire des tests sur quelques fichiers Divx (Fichiers lus avec Mplayer sur écran LCD HD-Ready).

Voici donc les résultats de la soirée :

- Fichier .mp4 (H264)

640x480 (4/3) = Fonctionnent parfaitement.

704x400 (16/9) = Fonctionnent parfaitement.

- Fichier .mkv (H264)

1280x720 (16/9) = Rame beaucoup

- Fichier . avi (XVID)

704x396 (16/9) = Fonctionnent parfaitement.

1280x720 (16/9) = Fonctionnent parfaitement.

- Fichier .avi (X264)

1280x720 (16/9) = Rame beaucoup.

Bon alors pour l'instant, je n'ai pu tester que quelques types de fichiers, mais déja on peut dire que c'est quand-même assez concluant.

Reste à voir ce qui fait que les fichiers H264 en HD ont du mal car pour des résolutions inférieures, c'est parfait...

Pour arriver à ce résultat, il a faut :

- installer Mplayer (je l'ai fait par l'interface graphique)

- modifier le fichier mplayer.conf (/etc/mplayer) comme suit :

dans video settings modifier "#vo=xv" en "vo=sdl" , "#monitoraspect=16:9" en "monitoraspect=16:9"

puis dans l'audio settings "ao=alsa," en "ao=sdl,"

Ensuite ouvrez un Terminal puis tapez "gmplayer -vo sdl" (il faut le faire une fois, après vous pourrez ouvrir directement les fichiers à la souris sans message d'erreur).

Voilà, je vais me coucher...

Sur ce bonne nuit ;) .

Modifié par pat18

Partager ce message


Lien vers message
Partager sur d'autres sites

salut,

j'ai installé Ubuntu 7.04 hier soir et j'ai des bandes noires sur le coté de mon écran sd

serait-il possible que quelqu'un m'explique le 1er post avec la configuration ecran cathodique ?

car je ne vois pas comment modifier les 2 fichiers Xorg et kboot pour les ecrans sd cathodique et sur ubuntu

merci de bien vouloir m'aider car ce n'est que mon 2ème jour sur linux chinese

Modifié par Disciple_of_Jedi_Mind

Partager ce message


Lien vers message
Partager sur d'autres sites
salut,

j'ai installé Ubuntu 7.04 hier soir et j'ai des bandes noires sur le coté de mon écran sd

serait-il possible que quelqu'un m'explique le 1er post avec la configuration ecran cathodique ?

car je ne vois pas comment modifier les 2 fichiers Xorg et kboot pour les ecrans sd cathodique et sur ubuntu

merci de bien vouloir m'aider car ce n'est que mon 2ème jour sur linux chinese

Salut,

Pour répondre à ton problème, tu dois :

- éditer ton fichier kboot.conf

- rajouter une ligne contenant : linux480i='/boot/vmlinux initrd=/boot/initrd.img root=/dev/sda1 quiet splash video=ps3fb:mode:129 rhgb'

- puis modifier la 1ere ligne default=linux en default=linux480i

C'est tout.

Voilà...........@+

Partager ce message


Lien vers message
Partager sur d'autres sites

un grand MERCI à toi pat18 ;)

je viens de tester et ça marche,

mais il me manque à présent des éléments, ça a en fait un poil trop grossi :marteau:

avec la config que tu m'a donné, ça m'a mis comme résolution: 720x480 et 30Hz

la résolution de base d'origine est : 576x460 et 25Hz

y a pas moyen d'avoir entre les 2 ? genre 680x480 ??

j'ai essayé la config en 480p et ça marche pas du tout,

on m'avait dit que Gnome était entièrement personnalisable mais il est impossible de changer

la résolution à sa convenance alors ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Le problème est que ta TV (la mienne aussi d'ailleurs) fait de l'overscan...

Dans la première ligne de ton kboot.conf tu dois avoir : linux=.....mode:1 rhgb , ça correspond à la résolution que tu avais au départ (soit 480i black border (voir page 1))

Maintenant tu es en mode:129 qui correspond au 480i mode fullscreen.

Je ne pense pas qu'il y ai un mode intermédiare...à toi de choisir celui qui te convient le mieux (perso ma tv fait tellement d'overscan que je ne voies même pas les barres d'outils, donc je préfère les bords noirs).

Sinon pour répondre à ta question sur le changement de résolution : non, on ne peut plus la changer une fois que Linux est chargé...le choix se fait au kboot (peu importe la distrib).

Voilà.

@+ ;)

Partager ce message


Lien vers message
Partager sur d'autres sites

ok merci beaucoup pour toutes ces précisions :ok:

finalement j'ai fait comme toi , je suis revenu en normal avec les bandes noires :(

en relisant le 1er post de ce topic, j'ai remarqué qu'il y avait une ligne qui n'a pas été abordé:

ydltext='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init 3'

à quoi correspond cette config ? peut-on l'adapter pour ubuntu ? et quelle résolution ça va etre ?

je sais que je pose beaucoup de questions ,mais si cela ne te dérange pas d'y répondre, tu m'enverra ravi :)

Partager ce message


Lien vers message
Partager sur d'autres sites

Ben à vrai dire, j'en sais rien du tout... blush

Mais je pense qu'il ne s'agit pas d'un mode graphique mais plutôt d'un mode en "ligne de commande".

Je peux pas t'aider sur ce coup là :P .

Partager ce message


Lien vers message
Partager sur d'autres sites
Ben à vrai dire, j'en sais rien du tout... blush

Mais je pense qu'il ne s'agit pas d'un mode graphique mais plutôt d'un mode en "ligne de commande".

Je peux pas t'aider sur ce coup là :P .

c'est ce que je me suis dit aussi, le "text" veux surement dire ça

j'ai installé le graphical kboot

et ça aurait sympa d'avoir l'option "ligne de commande" dans ce graphical kboot, au cas où je devrais taper

quelque chose au démarrage, mais je n'arrive pas à adapter la ligne pour ubuntu, c'est à la fin de la ligne de commande que je vois pas

pour YDL c'est donc :

ydltext='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init 3'

pour ubuntu ça serait donc:

linuxtext='/dev/sda1:/vmlinux initrd=/boot/initrd.img root=/dev/sda1 quiet splash

non ?? qu'en penses-tu ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut tout le monde,

Bon, pour ceux qui sont interessé, moi j'ai mis video=ps3fb:mode:6 dans mon kboot au lieu de video=ps3fb:mode:1, "1" correspond a du NTSC et 6 a du PAL, la résolution est meilleur, il y a quand même les bandes noir mais j'y voit mieux sur mon écran, c'est plus agréable qu'en NTSC (attention, il faut que la TV fasse le PAL, pour ce qui est de la console ça n'a pas d'importance, elle fait les 2 sous linux)

Partager ce message


Lien vers message
Partager sur d'autres sites

salut,

pour ceux sou linux il y a une commande a tester sur ps3:

gmplayer "$1" -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=nonkey:threads=8

ou

gmplayer "mon film divx hd" -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=nonkey:threads=8

vous me direz ok ou pas

sa allège la lecture mais on perd en qualité,

on sai pas tous avoir !!!!

@++

Partager ce message


Lien vers message
Partager sur d'autres sites

perso je préfere utiliser vlc ^^

Partager ce message


Lien vers message
Partager sur d'autres sites

salut les gueux,

qq'un a t"il réussi a avoir du fullscreen en 720p avec un hd-ready ? sans les bandes noires bien sur ?

je precise que, avec xubuntu 7.10 gutsy kernel 2.6.24, qd je mets "ps3videomode - v 35", j'ai les bandes, et qd je mets 163 pour du fs, j'ai l'image qui deborde car ma tv overscan !!!

j'ai lu qu'avec la commande "fbset", on pouvait modifier la resolution en reduisant pixel par pixel pour arriver a avoir du "fs".....

voila, si vous avez des infos, suis preneur

++

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant