Raj0r

Full Screen Mode

Messages recommandés

Bonjour à tous.

Aprés avoir installé linux et vlc, un autre problème se pose. J'avais des bandes noires sur les cotés de l'écran. Un peu ennuyeux pour lancer un divx en plein écran.

Voici la solution :

Allez dans "/etc/kboot.conf" et modifiez le fichier pour qu'il ressemble à ça.

# kboot.conf generated by anaconda

  • default=ydl
  • timeout=10
  • root=/dev/sda1
  • ydl='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init video=ps3fb:mode:133 rhgb'
  • ydl480i='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init video=ps3fb:mode:129 rhgb'
  • ydl1080i='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init video=ps3fb:mode:132 rhgb'
  • ydltext='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init 3'
    Source : http://www.edepot.com/playstation3.html
    A savoir que :
  • ps3videomode -v 1 black border mode 480i
  • ps3videomode -v 2 black border mode 480p
  • ps3videomode -v 3 black border mode 720p
  • ps3videomode -v 4 black border mode 1080i
  • ps3videomode -v 5 black border mode 1080p

  • ps3videomode -v 129 fullscreen mode 480i
  • ps3videomode -v 130 fullscreen mode 480p
  • ps3videomode -v 131 fullscreen mode 720p
  • ps3videomode -v 132 fullscreen mode 1080i
  • ps3videomode -v 133 fullscreen mode 1080p

Pour que la résolution soit en full screen il faut faire l'addition du mode + 128. POur moi qui veut être en 1080i je fais donc 4+128=132, qu'on retrouve ici dans le fichier kboot.conf -> video=ps3fb:mode:132

ydl1080i='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init video=ps3fb:mode:132 rhgb'

Dernière chose à faire modifier votre fichier /etc/X11/xorg.conf pour qu'il ressemble à ça.

Section "Screen"

Identifier "Screen0"

Device "Card0"

Monitor "Monitor0"

DefaultDepth 24

DefaultFbBPP 32

SubSection "Display"

Depth 8

FbBPP 32

Modes "1920x1080" "1280x720" "720x576" "720x480"

EndSubSection

SubSection "Display"

Depth 16

FbBPP 32

Modes "1920x1080" "1280x720" "720x576" "720x480"

EndSubSection

SubSection "Display"

Depth 24

FbBPP 32

EndSubSection

EndSection

Vous remarquez qu'il manque Modes pour le dernier bloc. Cela force le serverX à utiliser ce qu'il y a dans "/etc/kboot.conf.

Il ne vous reste plus qu'à taper ydl1080i quand " kboot :" s'affiche lors du boot sous linux.

Afin d'avoir 1080 par defaut modifier la ligne default=ydl par default=ydl1080i dans le fichier /etc/kboot.conf

Si vous tapez ps3videomode dans votre console il vous dira quel est votre résolution actuelle.

J'ai essayé de changer la résolution à partir de la console mais à chaque fois j'avais quelque chose de bizare par contre en tapant ydl1080i lors du boot ça passe nikel.

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites

une petite photo de ce que ca donne pour un film?

as tu testé des mkv h264? des divx avec bandes son ac3?

merci d'avance

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut et merci, je vais essayé cela, c'est ce qui me manquais :-)

PS: connaissez vous une commande équivalente à ifconfig sous yellow dog ? merci

++

Partager ce message


Lien vers message
Partager sur d'autres sites

Pour le mkv h264 à ce que j'ai lu ça marche avec mplayer.

Pour l'instant j'ai installé que VLC. Des que je test je vous en fais par.

En tout cas le full screen ca fait grave plaisir :)

Partager ce message


Lien vers message
Partager sur d'autres sites

si tu veux des extraits...

n'hésitent pas je t'en envois en 1080p

Partager ce message


Lien vers message
Partager sur d'autres sites

Je veux bien que tu me les envois.

Je n'ai que des gros fichier de ce format et pour faire des tests c'est pas comode.

Edit :

Je viens de tester avec un divx normal et ca passe nikel en full screen en passant par disque dur.

Par contre avec un avi gravé sur CD-R ca ne passe pas. L'image saccade et le son aussi.

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites

Voila je viens de tester avec du HD :

Tout saccade, H264 et WMD en 1920*1080. Je suis dégouté

Testé avec mplayer.

Pour installé mplayer :

* tapez dans la console " yum install mplayer "

* Lancer un film " mplayer -fs chemin ( -f c'est pour le full screen )

Alors pourquoi ca saccade ? Soit la console est brider sous linux soit c'est mplayer qui foire mais ca me semble peu probable vu qu'avec un core duo le HD est lisible sur un pc avec vlc ou mplayer.

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites

Afin d'avoir 1080 par defaut modifier la ligne default=ydl par default=ydl1080i dans le fichier /etc/kboot.conf

Partager ce message


Lien vers message
Partager sur d'autres sites

pas d'accés au gpu sur le linux de la ps3, donc pas d'accélération vidéo..

dommage éliane

Partager ce message


Lien vers message
Partager sur d'autres sites

Raj0r j'ai suivi à la lettre tes consignes mais je me retrouve avec une résolution plus grande que mon écran!!! Il y a un moyen d'afficher du 640 vu que je suis en composite?

Partager ce message


Lien vers message
Partager sur d'autres sites

C'est vrai que cette résolution "déborde". Je me croirais sur mon Amiga ;-)

(Et que ce soit sous Gentoo ou YDL).

En fait je pense qu'on est toujours en 720p (ou 1080p) mais que c'est le système qui "overscanne".

Ca serait bien d'avoir la "vraie" résolution. Je vais creuse un peu.

Partager ce message


Lien vers message
Partager sur d'autres sites
Il y a un moyen d'afficher du 640 vu que je suis en composite?

Le composite est un signal et je ne sais pas si c'est le même que l'Hdmi.

A la fin de la ligne dans le fichier kboot.conf il y a ecris rhgb ....

Je ne m'y connais pas la dedans. J'ai juste traduis le tuto.

Ca existe 640 p ou i ? Si ce n'est pas supporté par ps3videomode je crois que ce n'est pas possible ...

En fait je pense qu'on est toujours en 720p (ou 1080p) mais que c'est le système qui "overscanne".

Non. Si ta une télé qui supporte le 1080 alors du 1080 sera affiché.

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut,

J'ai suivi le tuto pour remédier à mon problème de bandes noires (ma résolution par défaut était 1164x644 il me semble). Malheureusement, une partie du bureau ydl n'est plus visible. Une bande d'environ 1cm est manquante de part et d'autre, impossible donc de voir correctement les barres de menu.

Pourtant mon écran est HDTV, je suis branché en HDMI et il supporte des résolutions 720p et 1080i que j'ai d'ailleurs testées en suivant les indications fournies: ie 128+3 pour le 720p et 128+4 pour le 1080i (résolution pour laquelle en plus du problème sus-cité un phénomène de scintillement vient s'ajouter. Linux essaye de s'afficher en 1080i alors que mon écran lui affiche du 720p. Mystère...)

Finalement, j'ai bidouillé mon écran, notament au niveau de l'extrapolation d'image, des modes panorama pour image 4:3, 16/9 etc... Rien n'y fait, mon image reste identique lors de l'affichage du bureau ydl.

Il me reste peut-être une solution, éditer le fichier xorg.conf pour le forcer à afficher une résolution batarde entre le 1280x720 et le 1164x644, mais cette solution ne me parait pas "propre".

Quelqu'un a-t-il une idée ou a-t-il trouvé une manip à effectuer sur l'écran? Le modèle que je possède est un sharp lc32rd1e.

Je comptais essayer la feisty d'ubuntu mais je pense que le problème restera le même, quelqu'un a-t-il testé?

Merci pour vos réponses, je vous tiendrai au courant si je trouve une solution.

A bientôt.

Partager ce message


Lien vers message
Partager sur d'autres sites

Sharp LC32RD1E -> 1366 x 768 -> 720p

Ta télé ne supporte pas le 1080i donc ressaie en rajoutant

Au lieu de 129 ( 1 + 128 ) essaye plutot 131 ( 3 + 128 )

Donc dans ton fichier faudra rajouter une ligne pour le 720p :

ydl720p='/dev/sda1:/vmlinux-2.6.16-20061110.ydl.2ps3 initrd=/dev/sda1:/initrd-2.6.16-20061110.ydl.2ps3.img root=/dev/sda2 init=/sbin/init video=ps3fb:mode:131 rhgb'

Et pour que ca devienne par défault tu change la ligne default=ydl en default=ydl720p

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites
Je comptais essayer la feisty d'ubuntu mais je pense que le problème restera le même, quelqu'un a-t-il testé?

Moi j'ai testé (YDL et Ubuntu) et le problème ne vient pas de l'OS mais plutôt de la TV.

En fait, j'ai le même problème que toi, ma tv (hdready) a tendance à overscaner l'image (elle zoome légerement l'image), et du coup en 720p (ou 1080i) l'image est plus grande que l'écran (j'avais déja remarqué ce problème avec ma X360).

C'est gênant mais on peut agrandir les barre d'outils (qui à la base sont presque invisibles puisque hors écran).

Si quelqu'un a une idée pour pouvoir afficher une résolution sur mesure (genre 1200x700) plutôt que qu'un mode "standard" style 720p, ce serait drôlement bien.

Partager ce message


Lien vers message
Partager sur d'autres sites

Merci Rajor,

Ton tutorial de début était trés clair, j'ai donc procéder exactement comme tu le décris plus haut pour le 720p. Apparement cela vient de ma tv tout comme pat18, elle overscanne. Je n'arrive pas à comprendre pourquoi elle n'affiche pas du 1366 x 768 ie 720p mais une résolution batarde.

Pour afficher une résolution sur mesure, peut-être suffit-il de modifier le fichier xorg.conf en ajoutant une section qui ressemble à ça:

SubSection "Display"

Depth 24

FbBPP 32

Modes "1200x700"

EndSubSection

A tester...

Partager ce message


Lien vers message
Partager sur d'autres sites

Sharp LC32RD1E->

Taille de l'écran 32''

Résolution 1366 x 768

Compatibilité HD (1080i/720p) Oui / Oui

Certification HD Ready Oui

Dsl j'avais lu que la ligne résolution. Effectivement il supporte le 1080i. Je ne comprends plus rien .... Je pensais que le 1080i était réservé au FULL HD.

http://forum.hardware.fr/hfr/VideoSon/HiFi...et_105005_1.htm

, n'oubliez pas de passer en "format reel" sur la tele pr pas avoir d'overscan

Testez ca.

Modifié par Raj0r

Partager ce message


Lien vers message
Partager sur d'autres sites

Bah, je n'ai pas de "format réel" sur ma tv... :(

Sinon pour ce qui et du 1080i, en fait pour qu'une tv ai le label "hd-ready" elle doit obligatoirement pouvoir afficher 720 lignes et être compatible 1080i.

Mais bon, en 1080i, elle n'affiche pas pour autant du 1920x1080..non, elle l'accepte puis l'adapte à sa résolution native (720p), ce qui entraîne du scintillement sur certaines tv.

Edit : Bon, ben après plusieurs essais infructueux, j'ai finalement opter pour l'option "ps3videomode -v 3 black border mode 720p" qui n'est pas plein écran mais presque et au moins je peux voir l'intégralité de l'image.

Donc dans la ligne du kboot.conf contenant : ....video=ps3fb:mode:131 rhgb , j'ai changé le mode:131 en mode:3

c'est pas parfait, mais c'est toujours un peu mieux...

Modifié par pat18

Partager ce message


Lien vers message
Partager sur d'autres sites

Petite précision supplémentaire pour les écrans HDready.

Ils sont capables d'afficher du 720p ou 1080i. Le 720p (pour progressif) rafraichit toutes les lignes à chaque rafraichissement d'écran, tandis que le mode 1080i (pour interlace) ne rafraichit grosso modo qu'une ligne sur deux à chaque rafraichissement: l'image est donc plus fine à condition qu'il n'y ait pas trop de mouvements (idéal donc pour un ordi, moins pour un matche de foot).

Partager ce message


Lien vers message
Partager sur d'autres sites

voila j'ai suivi le tuto et maintenant apres le kboot j'ai cece /init: eval: 1: ydl: not found

comment faire pour que ca redevienne normale car la je ne sais plus booter

(en appuyant sur tab je n'ai que install et rescut et en tapant ps3videomonde je suis en 6)

merci d'avance

Partager ce message


Lien vers message
Partager sur d'autres sites

Ton seul espoir est que tu aies fait une sauvegarde de ton fichier kboot.conf d'origine.

Si c'est le cas, tu bootes sur Live-cd et tu le remets en place ;) .

Partager ce message


Lien vers message
Partager sur d'autres sites
Ton seul espoir est que tu aies fait une sauvegarde de ton fichier kboot.conf d'origine.

Si c'est le cas, tu bootes sur Live-cd et tu le remets en place ;) .

non je ne l'ai pas fait lol

mais comment booter sur livecd avec yellowdog car ainsi quand je l'aurai reinstaller je reesayerai

Partager ce message


Lien vers message
Partager sur d'autres sites

Argh...

Moi aussi je m'étais fait avoir la 1ère fois. Maintenant je fais des bakups des fichiers que je modifie...je ne me ferais pas avoir une 2eme fois :P .

Sinon, pour ce qui est du Live-CD, j'avais pas compris que tu parlais de YDL..moi j'utilise Ubuntu. Mais bon, tu peux le télécharger ici : http://cdimage.ubuntu.com/ports/daily-live...powerpc+ps3.iso

Voilà ;) .

Edit : plutôt que de réinstaller tu peux télécharger ce Live-CD, booter dessus, puis modifier le kboot.conf de YDL.

Modifié par pat18

Partager ce message


Lien vers message
Partager sur d'autres sites

j'ai le cd de gentoo je suppose que se sera le meme

mais ce que je ne comprend pas c'est que j'ai bien suivi le tuto

donc ou est mon erreur (le full screen marche bien sur ecran cathodique)

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut tout le monde

Je n'arrive pas a avoir mon divx en plein ecran avec mplayer quand je mets full screen le divx reste en normal size avec la bande noir autour

Comment faire pour avoir une plein image ?

Merci d'avance

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant