Belgacomtv To Xbox Tv ?


Messages recommandés

Ouaw alors la tu as mis le paquet !!!

Alors alors...

Pour la modification des fichiers de B2XTV, pas de problemes.

J'ai créer les fichiers d'installation et de désinstallation du service mais la, petit probleme...

Je lance installservice.exe

Je vais vérifier dans les services et là, rien du tout.

Je prends donc le contenu de 'installservice.exe' que je copie/colle dans le prompt et la :

"The command line options couldn't be loaded, check that they are valid."

Voila, je n'ai pas été plus loin pour l'instant, tant que le service VLC n'est pas correctement configuré.

PS : encore merci pour le taff que tu fait pour moi !!! :ok:

Lien vers message
Partager sur d'autres sites

Ok,

Le service est lancé.

Premier test:

Les tests à effectuer:

1. Lances vlc, et tu demandes ouvrir un flux réseau, tu demandes rtsp, et tu tappes en adresse ip 127.0.0.1 ou 192.168.2.4 et en port 554, en complément d'adresse tu donnes un nom de chaîne, comme "une" ou "deux" ... en bas tu devrais avoir cette adresse qui apparaît:

CODE

rtsp://192.168.2.4:554/une

Tu valides, et tu devrais avoir la chaîne qui s'affiche, si ce n'est pas le cas, il y a un problème sur le serveur, reprends chacun des points dont j'ai parlé, et vois si tu n'as pas fait une erreur, sinon forum!!

Rien ne s'affiche. J'ai vérifier mon belgacomtv.conf, tout a l'air correct...

Lien vers message
Partager sur d'autres sites

oui le service est bien lancé !

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 error: Failed to connect with rtsp://192.168.2.4:554/une

main warning: no access_demux module matching "rtsp" could be loaded

main debug: creating access 'rtsp' path='192.168.2.4:554/une'

main debug: looking for access2 module: 5 candidates

main debug: net: connecting to 192.168.2.4 port 554

main debug: connection in progress

main debug: select timed out

main error: Connection to 192.168.2.4 port 554 failed: Connection timed out

access_realrtsp error: cannot connect to 192.168.2.4:554

access_realrtsp debug: could not connect to: 192.168.2.4:554/une

vcd debug: trying .cue file: 192.168.2.cue

vcd debug: could not find .cue file

access_file warning: 192.168.2.4:554/une: No such file or directory

cdda debug: trying .cue file: 192.168.2.cue

cdda debug: could not find .cue file

cdda warning: could not open 192.168.2.4:554/une

main warning: no access2 module matching "rtsp" could be loaded

main error: no suitable access module for `rtsp://192.168.2.4:554/une'

main debug: thread times: real 0m10.609375s, kernel 0m0.015625s, user 0m0.000000s

main debug: thread 3944 joined (input/input.c:412)

main: nothing to play

Lien vers message
Partager sur d'autres sites

Bon en fait, c'est con, il ne prends simplement pas le fichier de config au démarrage, simplement parce qu'il ne le trouve pas. En effet, je pensais de base qu'il le cherchait dans le dossier de VLC mais non, donc il faut lui indiquer le chemin complet d'accès.

Donc, tout d'abord, il faut arrêter le service, donc:

net stop VLC-BelgacomTV

ensuite il faut le désinstaller, avec le fichier uninstallService.bat

Ensuite, tu modifies les deux fichiers installService et uninstallService, en donnant un chemin complet pour l'accès au fichier belgacomtv.conf. Pour faire simple et éviter les problèmes d'espace, tu mets ce fichier directement sous C: ou sous D, mais directement à la racine, et donc tu changes belgacomtv.conf par C:\belgacomtv.conf

Ensuite, tu n'as plus qu'à resuivre la procédure, lancer installService puis net start .. dans la console, et le test VLC!

Désolé, j'ai du mal!

++

Lien vers message
Partager sur d'autres sites

OKOK

De fait ca parait logique mais....faut le savoir.... :D

Je suis désolé mais je ne saurais plus tester ça aujourd'hui car g du eteindre le pc fixe (trop de bruit pour madame...) et je n'ai rien d'installer sur le portable.

Mais je voulais quand même te parler de cette histoir d'ardresses ip (j'espere que ça ne posera pas de prob pour la suite...)

En fait sur le modem/routeur que j'ai, il y a 4 ports ethernet

Le port 1 et 2 sont pour l'adsl et les ports 3 et 4 sont des ports IDTV.

Ces ports 3 et 4 gérent le flux de BGTV.

Mais malheureusement ces ports ne sont joignables que par une ip du type 192.168.2.xxx

Alors que les ports 1 et 2 sont joignable via 192.168.1.xxx (et donc ma xbox est branchée sur un de ces ports)

Pour mon pc, je me suis donc branché sur le port 3 avec come ip 192.168.2.4

Ce que je comprends toujours pas c'est la passerelle par defaut : 192.168.2.1 alors que mon modem est en 192.168.1.1

Toujours est-il qu'avec cette configuration, je reçois les flux de BGTV sur mon pc et je conserve mon surf...

L'idéal serais d'avoir 2 cartes réseau comme expliqué ici...http://www.adsl-bc.org/mw/index.php/Belgacom_TV_sur_PC

J'ai sur mon portable une carte wifi + un port RJ45.

Je pourrais donc me rabattre sur cette solution dans le pire des cas...

Allez, j'ai fini ma tarine... lol

Je ne cesserais de te remercier et de remercier des personnes comme toi qui font part de leurs connaissances au profit des autres!!!

Belle leçon de partage ! :ok:

A demain pour de nouvelles aventures... lol

Lien vers message
Partager sur d'autres sites

Salut,

Et le pire, je le savais, mais j'avais oublié :(

OK, on attend demain, ah quel suspense!!!

Pour cette histoire d'IP tu m'avais déjà expliqué, j'avais oublié, mais bon, ce n'est pas très grave puisqu'en fait ça doit être le routeur qui se débrouille tout seul pour faire les bonnes redirections. D'ailleurs, si tu arrives à partager tes fichiers entre ta console et ton pc, ça ne devrait pas poser de problème.

Pour deux cartes réseaux, c'est une solution, mais vu que tu as un routeur, autant en profiter!

Pour le reste, ... :ok: ...

Bonne soirée/nuit!

++

Modifié par nioc bertheloneum
Lien vers message
Partager sur d'autres sites
Salut,

Et le pire, je le savais, mais j'avais oublié :(

OK, on attend demain, ah quel suspense!!!

Pour cette histoire d'IP tu m'avais déjà expliqué, j'avais oublié, mais bon, ce n'est pas très grave puisqu'en fait ça doit être le routeur qui se débrouille tout seul pour faire les bonnes redirections. D'ailleurs, si tu arrives à partager tes fichiers entre ta console et ton pc, ça ne devrait pas poser de problème.

Pour deux cartes réseaux, c'est une solution, mais vu que tu as un routeur, autant en profiter!

Pour le reste, ... :ok: ...

Bonne soirée/nuit!

++

Salut à tous !

Alors voila,

J'ai fait exactement ce que tu expliques, désinstaller le service, réinstaller le service en lui indiquant le chemin vers le fichier de config.

Placer ce fichier de config à la racine de mon hdd (mon C)

Lancer le service (j'ai vérifier, le service est bien lancé et vlc tourne bien dans le gestionnaire de taches)

Mais je n'ai toujours rien.

Dans les proprietes du services : Chemin d'acces des fichiers exécutables :

"C:\Program Files\VideoLAN\VLC\vlc.exe" -I ntservice --ntservice-extraintf telnet --rtsp-host 0.0.0.0:554 --vlm-conf C:\belgacomtv.conf

Toujours le meme message dans la console de VLC... :wacko:

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 debug: we will now try HTTP tunneling mode

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 error: Failed to connect with rtsp://192.168.2.4:554/une

main warning: no access_demux module matching "rtsp" could be loaded

main debug: creating access 'rtsp' path='192.168.2.4:554/une'

main debug: looking for access2 module: 5 candidates

main debug: net: connecting to 192.168.2.4 port 554

main debug: connection in progress

main debug: select timed out

main error: Connection to 192.168.2.4 port 554 failed: Connection timed out

access_realrtsp error: cannot connect to 192.168.2.4:554

access_realrtsp debug: could not connect to: 192.168.2.4:554/une

vcd debug: trying .cue file: 192.168.2.cue

vcd debug: could not find .cue file

access_file warning: 192.168.2.4:554/une: No such file or directory

cdda debug: trying .cue file: 192.168.2.cue

cdda debug: could not find .cue file

cdda warning: could not open 192.168.2.4:554/une

main warning: no access2 module matching "rtsp" could be loaded

main error: no suitable access module for `rtsp://192.168.2.4:554/une'

main debug: thread times: real 0m9.921875s, kernel 0m0.000000s, user 0m0.000000s

main debug: thread 3872 joined (input/input.c:412)

main: nothing to play

Modifié par xzibit0007
Lien vers message
Partager sur d'autres sites

Bon je vais refaire un résumé de ce que j'ai fait actuellement :

Au niveau réseau, j'ai changer 2-3 trucs :

1 carte réseau PCI connectée dans le port 3 de mon routeur (configurée en dhcp), elle reçoit l'ip 169.254.176.10 dans un masque de sous reseau 255.255.0.0

1 stick usb wifi configuré manuellement avec l'ip 192.168.1.4 dans un masque sous réseau 255.255.255.0 et la passerelle de mon routeur 192.168.1.1

La 1ere carte reseau me permet donc de recevoir bgtv sans probleme dans vlc (udp://@239.255.1.138:2276 par exemple) --> OK

La 2eme me permet de surfer et d'etre ok au niveau du transfert avec la xbox --> OK

J'ai un service "VLC-BelgacomTV" qui est lancé et qui fonctionne (vlc lancé dans le gestionnaire des taches) --> OK

Mon fichier de configuration vlc a la racine de mon C: qui contient ce que tu as mis + haut et le service VLC-BelgacomTV qui pointe dessus --> OK

Au cas ou je te met les Virtual Server configurés dans mon routeur :

192.168.1.5 --- TCP --- 31330 --- 31330

192.168.1.5 --- TCP --- 31331 --- 31331

192.168.1.4 --- TCP&UDP --- 554 --- 554

Voila voila.

Le message dans vlc lorsque j'essaye d'ouvrir "rtsp://192.168.1.4:554/une"

main debug: creating new input thread

main debug: waiting for thread completion

main debug: thread 3948 (input) created at priority 1 (input/input.c:265)

main debug: `rtsp://192.168.1.4:554/une' gives access `rtsp' demux `' path `192.168.1.4:554/une'

main debug: creating demux: access='rtsp' demux='' path='192.168.1.4:554/une'

main debug: looking for access_demux module: 1 candidate

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 debug: we will now try HTTP tunneling mode

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 error: Failed to connect with rtsp://192.168.1.4:554/une

main warning: no access_demux module matching "rtsp" could be loaded

main debug: creating access 'rtsp' path='192.168.1.4:554/une'

main debug: looking for access2 module: 5 candidates

main debug: net: connecting to 192.168.1.4 port 554

main debug: connection in progress

main debug: select timed out

main error: Connection to 192.168.1.4 port 554 failed: Connection timed out

access_realrtsp error: cannot connect to 192.168.1.4:554

access_realrtsp debug: could not connect to: 192.168.1.4:554/une

vcd debug: trying .cue file: 192.168.1.cue

vcd debug: could not find .cue file

access_file warning: 192.168.1.4:554/une: No such file or directory

cdda debug: trying .cue file: 192.168.1.cue

cdda debug: could not find .cue file

cdda warning: could not open 192.168.1.4:554/une

main warning: no access2 module matching "rtsp" could be loaded

main error: no suitable access module for `rtsp://192.168.1.4:554/une'

main debug: thread times: real 0m10.281250s, kernel 0m0.000000s, user 0m0.000000s

main debug: thread 3948 joined (input/input.c:412)

main: nothing to play

Lien vers message
Partager sur d'autres sites

Hum, bon on va faire quelques manips:

  1. Ouvres une console sur le pc qui a le service VLC-BelgacomTV d'installé, et tappes la commande suivante:
    telnet 127.0.0.1 4212

    Il va te demandé un mot de passe et tu vas lui donner

    admin

    Ensuite tu vas être connecté au telnet de ton serveur. Tu tappes alors

    show

    . Il va t'indiquer le nombre de flux VOD de disponible. Vérifies qu'il y en a. Si tu as 0 flux, ça veux dire que ton fichier est soit faux, soit il n'a toujours pas été pris en compte. Il te faut donc vérifier les différents points dont j'ai parlé dans les posts précédents. Maintenant, tu en as plus d'un. Tu tappes la commande

    show one

    et tu vérifies les informations qui s'affichent. Théoriquement, tu devrais avoir les informations qui sont dans le fichier de configuration. Si tout est bon là, on va tenter autre chose. Pour quitter le telnet, tu tappes la commande

    exit


  2. On va ajouter un flux VOD simple, c'est à dire un fichier. Tu vas donc arrêter ton service. Tu vas modifier ton fichier de configuration, en ajoutant une configuration pour une vidéo. Trouves une vidéo sur ton disque dur et récupères son adresse complète. Ajoutes une entrée dans ton fichier de configuration, comme ceci:
    new bla vod enabledsetup bla mux mpeg1setup bla input "C:\\chemin\\vers\\le\\fichier\\video\\video.ext"

    Si tu peux éviter les chemins et les noms de fichiers avec des caractères spéciaux et des espaces, c'est le top! Tu relances ensuite ton service. Et tu tentes d'accéder à cette vidéo via VLC avec l'adresse:

    rtsp://127.0.0.1/bla

    Si ça marche, on va pouvoir passer au point 3. Sinon, vérifies que tous les points déjà abordés sont bien juste.

  3. On va rendre le serveur VOD visible et afficher les messages, pour voir quelles sont les erreurs qu'il donne. Pour cela, tu stoppes ton service. Et dans une console, tu te places dans le dossier de VLC, et tu tappes la commande suivante:
    vlc.exe --extraintf telnet --rtsp-host 0.0.0.0:554 --vlm-conf C:\belgacomtv.conf

    Dans la fenêtre de VLC qui s'ouvre, tu affiches les messages, et tu regardes s'il n'y a pas d'erreurs. Dans une seconde fenêtre de VLC, tu ouvres un flux locale, et tu regardes ce qu'il se passe. Si ça ne passe pas, enlèves la ligne avec "mux mpeg1" dans le fichier de config, et tu redémarres le serveur.

++

Lien vers message
Partager sur d'autres sites

Je viens de me rendre compte d'un truc, le serveur VOD de VLC n'a pas l'air d'aimer le coup du mpeg1, on va donc faire autrement avec du mpeg2.

Voici les nouvelles lignes du fichier de config.

new une vod enabledsetup une mux mp2tsetup une output #transcode{vcodec=mp2v,fps=25}setup une input udp://@239.255.1.138:2276

Voilà,

++

Lien vers message
Partager sur d'autres sites

Ok ok,

alors au point N°1 :

lors du "show":

media : (0 broadcats - 0vod)

sheldule

J'ai fait l'étape 2 egalement mais je penses qu'a partir du moment ou je n'ai pas de 'flux VOD de disponible' ça n'ira pas.

Moi c'est cette ligne dans vlc qui m'étonne un peu :

main warning: no access_demux module matching "rtsp" could be loaded

Modifié par xzibit0007
Lien vers message
Partager sur d'autres sites

Hum en effet, c'est problématique, essayes tout de même avec une vidéo simple. Testes aussi de changer le mux avec les nouvelles valeurs que je t'ai donné. Si le flux udp ne passe pas, on essaiera de faire autrement, mais je voudrais voir si au moins une vidéo passe. Normalement, il n'y a pas de problème avec une vidéo, je viens de réessayer. pour le flux, je ne peux pas tester, n'ayant pas accès à tes flux udp, je regarderais si je ne peux pas tester avec d'autres flux. Mais tout d'abord, une vidéo toute simple...

++

Lien vers message
Partager sur d'autres sites

Oui oui mais meme avec une vidéo simple, ca ne fonctionne pas.

Mon fichier .conf :

# VLC media player VLM command batch

# http://www.videolan.org/vlc/

new bla vod enabled

setup bla mux mpeg1

setup bla input "C:\\Chiptricks.avi"

# Chaîne : Une

new une vod enabled

setup une mux mp2t

setup une output #transcode{vcodec=mp2v,fps=25}

setup une input udp://@239.255.1.138:2276

# Chaîne : Deux

new deux vod enabled

setup deux mux mpeg1

setup deux input udp://@239.255.1.139:2278

J'essaye de l'ouvrir avec : rtsp://127.0.0.1/bla

Message de vlc :

main debug: adding playlist item `rtsp://127.0.0.1/bla' ( rtsp://127.0.0.1/bla )

main debug: creating new input thread

main debug: waiting for thread completion

main debug: thread 3944 (input) created at priority 1 (input/input.c:265)

main debug: creating statistics handler

main debug: `rtsp://127.0.0.1/bla' gives access `rtsp' demux `' path `127.0.0.1/bla'

main debug: creating demux: access='rtsp' demux='' path='127.0.0.1/bla'

main debug: looking for access_demux module: 1 candidate

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 debug: we will now try HTTP tunneling mode

live555 debug: DESCRIBE failed with 0: connect() failed: Unknown error

live555 error: Failed to connect with rtsp://127.0.0.1/bla

main warning: no access_demux module matching "rtsp" could be loaded

main debug: creating access 'rtsp' path='127.0.0.1/bla'

main debug: looking for access2 module: 5 candidates

main debug: net: connecting to 127.0.0.1 port 554

main debug: connection in progress

main debug: select timed out

main error: Connection to 127.0.0.1 port 554 failed: Connection timed out

access_realrtsp error: cannot connect to 127.0.0.1:554

access_realrtsp debug: could not connect to: 127.0.0.1/bla

vcd debug: trying .cue file: 127.0.0.cue

vcd debug: could not find .cue file

access_file warning: 127.0.0.1/bla: No such file or directory

cdda debug: trying .cue file: 127.0.0.cue

cdda debug: could not find .cue file

cdda warning: could not open 127.0.0.1/bla

main warning: no access2 module matching "rtsp" could be loaded

main error: no suitable access module for `rtsp://127.0.0.1/bla'

main debug: thread times: real 0m10.015625s, kernel 0m0.015625s, user 0m0.000000s

main debug: thread 3944 joined (input/input.c:412)

main: nothing to play

PS : si tu veux, tu peux prendre la main sur mon pc via VNC, pour jetter un oeil...

Lien vers message
Partager sur d'autres sites

Merci, c'est sympa de me faire confiance, mais on va tenter de le faire à l'ancienne, pour l'instant.

Tu vas refaire ton fichier de configuration (ou un autre, tu fais une sauvegarde de l'ancien), et tu mets uniquement la configuration de bla (d'ailleurs, mets la en mp2t + le transcode). Relances le serveur, en visuel, mets les messages, effaces les textes qui s'affichent. Refais un test, si, du côté serveur, rien ne s'affiche c'est qu'il y a une couille dans le potage. Vérifies par telnet que tout est bien comme il faut.

Tiens moi au courant,

++

PS: si ça ne marche, toujours pas, on passe en MSN, ça ira plus vite, je te mets mon adresse en MP

Lien vers message
Partager sur d'autres sites

Salut à tous,

Un petit message pour faire le point avec ceux qui ont suivi cette aventure!

Le premier problème qui empêchait le chargement du fichier de config était dû à un mauvais encodage des caractères (eh oui, parfois c'est peu de chose), un enregistrement en UTF8 et VLC chargeait la config.

Les problèmes qui ont suivi ont été de trouver les bons paramètres au niveau du multiplexage de la vidéo et de l'audio et du réencodage du flux. Malheureusement pour un flux tel que celui provenant de Belgacom, le réencodage produisait une forte compression du flux et donc un flux de mauvaise qualité. Des tests avec d'autres encodeurs ne nous ont pas permis d'obtenir une bonne qualité d'image. La solution "simple" a donc été abandonnée!

La solution est venue des premiers tests de xzibit0007 en broadcast. Nous avons créé un nouveau fichier de config pour diffuser en broadcast. Le problème, c'était de faire partir et d'arrêter le flux qui nous intéressait (les lancer tous en même temps demande une grande ressource réseau et surtout est impossible avec BelgacomTV puisque c'est une TV monoposte) Il a donc fallu reconfigurer F2XTV (devenu B2XTV à l'occasion) pour que la gestion des chaînes ne se fasse plus par le proxy rtsp2http mais par un système intermédiaire par commandes telnet.

Je passe bien entendu sur les problèmes inhérent à l'adaptation d'un script existant, mais le résultat obtenu est un système permettant la visualisation des chaînes de BelgacomTV sur XBMC. Actuellement, le système d'enregistrement n'est pas fonctionnel mais devrait l'être dans les jours qui suivent après une réécriture modulaire du script F2XTV et donc B2XTV.

Merci à xzibit0007 pour tous les tests nécessaires et sa patience, d'autres auraient abandonnées avant. Merci aussi à Alex pour la solution du bug du bouclage (entier en string, il fallait y penser!).

++

Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant