zeugma546

Xecuter SX Pro Switch patchée

Messages recommandés

Bonjour. J'aimerais savoir si le problème des Switchs patchées est toujours d'actualité ou si la team SX a réglé le problème avec le SX OS 2.8 Beta. Est ce que le Xecuter SX Pro est désormais compatible avec toutes les Switchs ?

Merci.

Partager ce message


Lien vers message
Partager sur d'autres sites

salut,

si la team Xecuter y travaillait, ça se saurait...Ils attendent tranquillement, le bec grand ouvert, que les vrais hackers (SciresM et compagnie) fassent tout le boulot à leur place.

Sauf que, pour l'instant, malheureusement pour les désirs capitalistes de Xecuter, seules les consoles nouvelle génération en 3.x et 4.x peuvent être bootées sous Atmosphère. Ça repose sur deux failles purement software, utilisées conjointement, et qui ne seront jamais compatibles avec la dernière version du firmware (branche 8.x), qui corrige tout ça. Et comme les modèles Mariko sont de plus en plus vendues en 8.x, c'est mort d'avance.

 

Bref, pas demain la veille que Xecuter sortira quelque chose de concret, non repompé des petits copains hackers bénévoles <_<
Il ne faut rien attendre d'eux, c'est ce qu'il y a de plus sage à faire.

Partager ce message


Lien vers message
Partager sur d'autres sites
Posté(e) (modifié)

Pour résumer, tout dépends du FW de la Switch patchée:

- En dessous de 4.X, les Switchs n'étaient pas encore patchées

- En 4.X, si la console n'a pas de "super NAG", il y a déjà Caffeine qui permet de lancer un CFW (voir https://pegascape.sdsetup.com/): attention à ne pas faire de betise qui brickerait irrémédiablement la console (comme activer l'AutoRCM)

- Entre 5.X et 7.X, rien n'est encore sorti mais il y a de l'espoir (d'après les hackers principaux de la scene)

- En 8.X, ça risque d'être très compliqué...

Comme le dit Badablek, il est inutile d'espérer quoi que ce soit de la part de la team Xecuter sur ce point: il faut mieux se tourner vers les hackers indépendants comme SciresM (voir https://twitter.com/SciresM).

Cela dit, je suis étonné que la team Xecuter n'ait pas encore pompé Caffeine qui permet aux Switch patchées en FW 4.X de lancer un CFW.

 

Modifié par OperationNT

Partager ce message


Lien vers message
Partager sur d'autres sites

à mon avis, le risque de brick étant à mon maximum sur les unités iPatched, la team Xecuter a trop peur d'un retour de bâton contre-productif pour ses petites affaires très lucratives.
un SXOS brickeur de Switch, ça ferait mauvais genre redface (d'autant qu'ils ne sont pas débutants en la matière, avec le brickeur volontairement intégré à leurs premières versions de SXOS)

Il y a déjà bien assez de Switch non patchées dans la nature pour ne pas trop se soucier des iPatched / Mariko. Peut-être qu'une fois le filon épuisé, ils y repenseront (mais vu les millions d'unités non patchées, ça n'arrivera pas avant longtemps).

 

à moins d'une faille béante à la sauce RCM, je doute qu'ils (Xecuter) mettent ls mains dans le cambouis avant un bon bout de temps.

Partager ce message


Lien vers message
Partager sur d'autres sites
Le 17/08/2019 à 13:31, zeugma546 a dit :

désormais compatible avec toutes les Switchs ?

Il semblerait que les hackers ont réussi à dumper le bootrom des nouvelles Switchs:

Malheureusement, j'ai l'impression qu'après leur analyse de ce bootrom, la confirmation que c'est mal barré vient de tomber:

http://wololo.net/2019/08/21/sciresm-doesnt-believe-newer-switch-units-will-see-atmosphere/

 

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant