Darkdjack

Console en 5.1.0 mais jeux réclamant Update

Messages recommandés

Posté(e) (modifié)

Bonjour à tous,

Ca fait un bail de bail que je ne m'étais plus connecté au site. Ravi de voir qu'il tourne toujours ! :)

Voila j'ai une question car je suis un peu perdu et je ne comprend plus rien.

J'ai ma switch en 5.1.0 et j'utilise le SX Os. Jusqu'ici, aucun problème, tout se lance sans souci et donc pas besoin de plus. .. Mais depuis ce matin, j'ai des NSP qui demandent des Mise à jours de la console. De là je me suis demandé si je pouvais update ma console.. Apparemment la réponse est non. En farfouillant, j'ai compris qu'il existait des EMuNAND, des ReinX, des Atmosphere, des ChoixDuJour et autre TegraRMC. Bref je suis complètement largué et la plupart des tutos partent d'une console sans SX OS.

Bref.. quelle est la meilleure solution pour mon cas sachant que je cherche à me prendre la tête au minimum ?

Merci pour vos avis et conseils

 

Modifié par Darkdjack

Partager ce message


Lien vers message
Partager sur d'autres sites

 Salut,

avec SXOS, le plus simple reste de mettre en place une emuNAND 7.x

Ton souci est un classique. Les algorithmes de chiffrement évoluent avec les versions de firmware. Donc, un jeu récent, qui utile un chiffrement récent, ne pourra fonctionner que sur un firmware récent. Si tu tentes de l'installer en 5.x, au pire il te jettera une erreur NCA, au mieux il ignorera l'erreur et installera un truc inutilisable. 

Lithium / Tinfoil intègre depuis peu le chiffrement à la volée pour contourner le problème, tu peux aussi y jeter un oeil (mais de mémoire cette solution ne sera pas éternelle ni forcément compatible avec tout). À tenter. 

https://gx-mod.com/tinfoil-lithium-1-55/

Ps Les managers de NSP peuvent ignorer le firmware minimum mais ça ne suffit plus, surtout quand il y a un gouffre entre deux versions de firmware (de 5.x à 7.x par exemple). C'est pourquoi Blawar propose le rechiffrement à la volée avec un algorithme plus ancien

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut,

J'avais le même problème avec ma Switch et Atmosphère. J'ai maj en 6.2.0 avec ChoixdujourNX (très simple au passage) et maintenant tous mes NSP fonctionnent bien.

++

Partager ce message


Lien vers message
Partager sur d'autres sites
Posté(e) (modifié)

Ok merci pour votre aide. Je ne suis plus vraiment l'actu du coup lorsque j'ai remis le nez dedans, je n'ai absolument plus rien capté. Je comprend mieux à présent.

Je vais tenter vos solutions et aller au plus simple.

Question bonus, puis-je me passer de SXOS en installant d'autres choses comme Reinx ou Atmosphere ?

Merci :)

Modifié par Darkdjack

Partager ce message


Lien vers message
Partager sur d'autres sites

SXOS est dispensable, sans aucun souci !

tu mets Atmosphère (0.8.6 actuellement) avec les patches ES de The-4n, tu MAJ ta console en 6.2 avec ChoiDuJourNX histoire d'être tranquille (pour l'instant) avec les jeux récents, et tu auras l'équivalent (en mieux) de cette solution payante de Xecuter.

Seuls bémols du Custom Firmware:

  • pas (encore) d'emuNAND possible (mais ils y travaillent)
  • pas de support des XCI (mais ils sont désormais installables avec les managers de NSP)

Il te faudra bien évidemment un moyen d'injecter le payload. Je ne sais pas si le dongle SXOS permet de choisir le payload, mais au pire tu peux passer par TegraRCM GUI (PC) ou Rekado (Android) pour injecter Fusée-Gelée (0.8.4 actuellement)

Partager ce message


Lien vers message
Partager sur d'autres sites

Oui c'est exactement ce petit détail qui me chagrine. Je me ballade avec une petite trousse où j'ai le dongle et le nécessaire SXos pour booter dans le train, la voiture ou au boulot sans avoir besoin d'un ordinateur ou autre en cas de rade de batterie dans la journée. C'est un peu ma trousse à maquillage à moi lol. Devoir passer par un appareil tiers pour booter m'ennuie un peu. (si j'ai bien compris le truc ).

Ok..  je note la solution Atmosphère et te remercie, jy reviendrais si je m'en sors pas avec l' Emunand 7.X.

Merci encore pour toutes les infos et les liens, direct simple et efficace :) .... Je vous tiens informé

 

Partager ce message


Lien vers message
Partager sur d'autres sites

bon j'ai vérifié, le dongle SXOS a une option pour booter un payload externe, qu'il suffit de placer à la racine de la microSD.

Donc, en mettant fusée-gelée à la racine de la microSD, avec ton dongle SXOS, tu pourras démarrer Atmosphère sans souci.
Il faut juste maintenir Volume+ au démarrage pour éviter l'autoboot de SXOS

https://gbatemp.net/threads/changing-payloads-on-sx-pro.508271/

Partager ce message


Lien vers message
Partager sur d'autres sites
Posté(e) (modifié)

En fait, hier, pour faire des tests, j'ai mis REINX sur ma SD et j'ai été dans le menu SXOS pour lui demander de lancer un playload. De là j'ai choisi REinx.bin et ça m'a fait démarré sur... l'OS natif de la console. J'ai pas tout capté. Ensuite j'ai mis Atmosphere à la racine aussi et le menu SXOS ne le voyait même pas... Bref je me suis dis que j'étais en train de m'aventurer dans un truc que je ne maîtrisais absolument pas et qu'il fallait plutôt lâcher l'affaire. 

Bon le truc cool c'est que là, j'ai dumpé ma NAND, backupé le contenu de ma SD et que jétais ready pour créer l'emunand avec SXos... et en voulant récupérer la dernière version du boot...tadammmm :D. ON dirait que le sort veut que je fonctionne avec fusée-gelée et atmosphere :) 

image.png 

 

 

Modifié par Darkdjack

Partager ce message


Lien vers message
Partager sur d'autres sites

quand ça veut pas, ça veut pas :D

il faut bien vérifier ce qu'il peut charger, SXOS. Est-ce que c'est le payload RCM qui charge ensuite le binaire du CFW, ou est-ce que c'est directement le binaire du CFW (phase 2 du boot, "secondary"). Je ne connais pas du tout SXOS, mais je dirais qu'il faut charger le payload RCM (il doit faire un chain load payload SXOS > Fusée-gelée) puisque c'est comme ça que ça marche avec Hekate/Kosmos (et vu que Xecuter pique tout le boulot des autres, ça doit marcher pareil :) ).

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjour,

 

pourquoi pas mettre la console en 7.01 ??????

Partager ce message


Lien vers message
Partager sur d'autres sites

parce qu'elle apporte plus d'ennuis qu'autre chose, nécessitant l'utilisation de "Sept" en plus du payload classique.

plus de couches de protection, plus de chance que ça buggue. La 6.2 est donc (pour l'instant) parfaite. D'autant plus avec l'option de rechiffrement en crypto standard au moment d'installer des NSP avec Tinfoil / Lithium.

Partager ce message


Lien vers message
Partager sur d'autres sites

J'ai trouvé une version 2.6.1 du boot SXOs et  j'ai lancé la création de l'emunand. Voyons voir ce que ça donne. Si ça foire, je me lance dans Fusee-gelee et autre atmosphere.. 

Merci en tout cas 

Partager ce message


Lien vers message
Partager sur d'autres sites
il y a 21 minutes, Badablek a dit :

parce qu'elle apporte plus d'ennuis qu'autre chose, nécessitant l'utilisation de "Sept" en plus du payload classique.

plus de couches de protection, plus de chance que ça buggue. La 6.2 est donc (pour l'instant) parfaite. D'autant plus avec l'option de rechiffrement en crypto standard au moment d'installer des NSP avec Tinfoil / Lithium.

 

Avec SXos ( comme il l'a ), j'ai aucun problème d'installation ou de lancement de jeu, après j'en ai pas beaucoup, mais le peu que j'ai marche parfaitement.

Partager ce message


Lien vers message
Partager sur d'autres sites

Oui ça fonctionne aussi mais la 6.2.0 est plus "hackfriendly" on va dire :)

Donc si on a le choix, c'est mieux de rester en 6.2.0, après si on a fait la maj par erreur et qu'on se retrouve en 7.01 ça fonctionne aussi.

Partager ce message


Lien vers message
Partager sur d'autres sites

Ok... bon alors.... l'EmuNand semble être installée. Par contre quand je boot sur l'Emunand, je vois que je suis exactement dans la meme configuration qu'avant c'est a dire en 5.1.0.

De là, si je comprend bien, c'est soit je lance ChoixDujour et je choisis d'installer le firmware 6.2 soit je lance une mise a jour direct via Emunand ? Sachant que l'option 1 avec ChoixDujour est mieux car plus Hackfriendly ?

Thanks

 

Partager ce message


Lien vers message
Partager sur d'autres sites

attention, je n'ai jamais dit que ça ne marchait pas, KGB64. Juste dit, comme l'a résumé Dingoo juste au dessus, que c'est plus "hack friendly" en 6.x.

d'ailleurs tu te souviens combien de temps tu as attendu le support du 7.x ??? C'est sûr que là, ils ont du se sortir les doigts pour coder avec leurs petites mimines, puisqu'ils ne pouvaient pas juste pomper le boulot des hackers bénévoles. Donc quand on parle de firmware 7.x avec SXOS, faut pas non plus garder trop la confiance :ok:

 

Pour l'update de l'emuNAND, perso, je préfère m'abstenir de répondre, c'est hors de mes compétences. Ce qui est sûr, c'est que SXOS ne réinvente pas la poudre : il est tout à fait normal que tu sois dans la même version que ton vrai firmware, puisque l'emuNAND a été générée depuis ta propre NAND. Un truc qui aurait été intelligent de leur part, c'est permettre aux utilisateurs de donner un firmware précis à installer au moment de faire l'emuNAND, ou bien encore prévoir une étape supplémentaire en fin de génération d'emuNAND pour le faire.

Partager ce message


Lien vers message
Partager sur d'autres sites
Posté(e) (modifié)

Et bien c'est exactement ce que je croyais... Je pensais que l'Emunand me permettrais de choisir mon firmware ou un truc dans le genre pour créer une nand avec la version qu'on souhaite :wacko:

Bref jai installé CHoixDujour, jai choisis d'installer 6.2.0 et ça à l'air de rouler.

 

Modifié par Darkdjack

Partager ce message


Lien vers message
Partager sur d'autres sites
Posté(e) (modifié)

Bingo... Voila c'est le résultat que je ne voulais pas obtenir lol

Je reboot, je choisis Emunand fraichment updaté en 6.2 avec ChoixDuJour et là.. Ecran noir  après le logo "Nintendo" :mellow:

J'ai loupé une étape ? :o

Modifié par Darkdjack

Partager ce message


Lien vers message
Partager sur d'autres sites

C'est pas l'histoire de l'autoRCM qui ne serait pas activé ? Je vais laisser Bada répondre car je n'en sais pas plus à ce sujet...

Partager ce message


Lien vers message
Partager sur d'autres sites

Ta sd est en exFat ? ta choisis le firmware en exfat du coup ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Ouais j'ai lu quelques trucs la dessus effectivement sur l'AutoCRM mais a vrai dire, j'ai rien touché la dessus faudrait que je test mais c'est trop tard car dans le doute, j'ai désactivé l'EmuNand et j'ai pu accéder de nouveau aux Homebrews ect en bootant sur le CFW d'SXOS. 

Partant de là, j'ai préféré effacer l'EmuNand foireuse et en refaire une autre pour être sur. Je vais recommencer et voir..  et oui j'avais choisi ExFat pour que cela Matche avec ma SD ;) 

Partager ce message


Lien vers message
Partager sur d'autres sites

l'autoRCM n'intervient normalement pas dans le processus de boot de l'emuNAND.

par contre pour que ça boote bien, il faut que la version de SXOS le supporte aussi. Tu es sûr que la version que tu as chopée gère le firmware 6.2 (en emuNAND) ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Yes , il est même censé supporter le 7.x..

ben en tout cas, après avoir refait le tout au propre ça fonctionne enfin ! A moi l'emuNand en 6.2 ! :)

Merci pour tout 

Partager ce message


Lien vers message
Partager sur d'autres sites

l'emuNAND tu pouvais la passer en 7.x ;)

c'est le firmware officiel qu'il vaut mieux garder en 6.x maxi

Partager ce message


Lien vers message
Partager sur d'autres sites

N'oublie pas d'enlever l'auto RCM que ta mis choixdujour, si ta batterie arrive a zero, tu vas galérer

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant