zouzzz

Backup sur carte SD depuis NGC pucée

Messages recommandés

Salut les gueux,

 

Je possède une NGC pucée Viper Extrem, sans coque 12cm.

Je possède un WiSD Memory Adapter (comme celui-ci : www.ebay.com ) et des cartes SD, adaptateur jamais servi, neuf depuis des années.

J'aimerai lancer des backups depuis une carte SD. Est-ce possible ?

Merci de votre aide.

Modifié par zouzzz

Partager ce message


Lien vers message
Partager sur d'autres sites

salut zouzzz,

c'est possible avec swiss-gc : https://www.gc-forever.com/wiki/index.php?title=Swiss

perso je me suis fabriqué mon propre adaptateur SD, avec une memory card HS et un port SD, et swiss-gc fonctionne très bien. Vu que tu as une puce, tu peux booter directement swiss-gc depuis un DVD-R, peut-être même directement de la puce si elle dispose d'un espace mémoire à cet effet, voire encore mieux (du moins à mon goût sur ma console non pucée), en passant par la faille Zelda Wind Waker GC : https://www.gc-forever.com/forums/viewtopic.php?t=3311

Il suffit d'avoir une Wii hackée pour injecter très facilement un homebrew (swiss-gc par exemple) sur la memory card. Ensuite, tu démarres Zelda et l'exploit boote directement sur le homebrew.

Y'a moyen de faire de belles choses sur GC, et encore plus fort, même pas (plus) besoin de puce pour ça !

ps : j'utilise régulièrement l'exploit Zelda pour profiter de GBI avec mon Gameboy Player. Un must-have ;)
ps2 : l'exploit Zelda Twilight Princess marche bien également...mais le déclenchement de l'exploit est plus long. Avec WW, il suffit de lancer le jeu.

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut et merci beaucoup Badablek,

Je savais que je te trouverai sur cette question. :)

Je n'ai pas de coque 12 cm, je n'arrive pas à en trouver d'ailleurs, ICEDCUBE ou autre du coup j'essaie de m'en passer.

J'ai réussi à faire reconnaître la Viper à mon PC Windows 10 en passant par un Oracle VM Virtual Box Windows XP.

J'ai installé Swiss r431 (spécial Viper) sur la puce et j'ai pu booter dessus. Le WiSD  a été reconnu sans problème.

J'ai testé le premier backup que j'avais : MK DD (format gcm ou iso) mais il ne se lance pas : écran noir.

Partager ce message


Lien vers message
Partager sur d'autres sites

les coques 12cm, c'est de la daube de toute façon ^___^
tu ne perds vraiment rien. J'avais pucé la console d'un pote à l'époque, avec coque 12cm, c'était pas terrible (plastiques de très mauvaise qualité et capot "mou" à cause d'un ressort merdique)

tu as bien utilisé un iso 1:1 (1.35Go, si possible avec un hash vérifié auprès de redump.org) ? De mémoire, il n'aime pas les isos qui ont été trimmés (problème d'alignement des données). Je ne me souviens pas avoir eu le moindre problème la dernière fois que j'ai testé (mais ça remonte déjà à quelques temps)

si c'est bien un iso 1:1 dont le hash correspond, teste vite fait avec la version standard de swiss (si tu as un mini DVD-R, c'est juste parfait). Peut-être que la version spéciale viper est frelatée ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Je ne peux pas installer le DOL de SWISS "normal" (trop grand), je suis obligé de placer le DOL spécial Viper.

 

Le CRC 32 de l'iso de mon MK DD est bon : a211edb6 vérifié ici : http://redump.org/disc/851/

Je dois rater une manip, je m'y prends bien :

Je place un jeu mini DVD (est-ce vraiment necessaire ?).

Je place ma carte SD avec l'ISO (ou mon GCM) dans le WiSD.

Je place le WISD dans le slot 1 carte mémoire NGC.

Je boote sur Swiss.

J'explore la carte SD et je choisis mon ISO (ou mon GCM) et le lance jusqu'à 100% puis...

Black screen.

Modifié par zouzzz

Partager ce message


Lien vers message
Partager sur d'autres sites

je ne parlais pas d'installer swiss, mais de le lancer, depuis un média type mini DVD-RW ;)

sinon, de mémoire (faut que je fouine un peu), il me semble qu'il existe une sorte de launcher très light qui permet de lancer des homebrews depuis un adaptateur SD. Je crois que ça permet justement de passer outre les limitations d'espace des puces.

À l'époque de mes bidouilles, je crois bien que j'utilisais un truc du style...je vais faire un peu de spéléo.

 

je ne me souviens pas qu'il fallait un jeu dans la console...ce n'est pas utile uniquement que pour les jeux sur plusieurs DVD ? Je suis un peu rouillé avec swiss, mes souvenirs sont un peu brumeux. En tout cas, tu sembles faire exactement ce qu'il faut. La seule chose qui me chagrine, c'est que tu mets l'adaptateur dans le slot 1...je ne sais pas pourquoi...mais il me semble qu'il est préférable d'utiliser le port 2 (le port 1 étant réservé à la memory card...je crois que swiss est assez pointilleux à ce sujet)

 

EDIT : samerlipopette, mais c'est bien sur ! Comment j'ai pu oublier ça...la base de la base...c'est sdload, le launcher de homebrews :)
si le port 2 ne donne rien, je te dirais d'installer sdload dans la puce, de mettre siwss-gc (version "normale") sur la carte SD, et de booter swiss depuis sdload. Juste pour être sûr que ce n'est pas bêtement la version viper qui merdouille.

https://www.gc-forever.com/forums/viewtopic.php?t=169

Partager ce message


Lien vers message
Partager sur d'autres sites

Je n'ai pas de mini DVD :/

J'ai testé le port 1 et le port 2 : pareil.

J'ai tenté un homebrew (Fruit'Y de  Retroguru), il se lance bien avec Swiss.

Bon, je vais faire une pause, je regratterai demain ou après demain, ça fait parfois du bien de repartir l'esprit clair.

Merci de toute ton aide, ça booste mes recherches.

Bonne soirée Badablek.

Modifié par zouzzz

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut Badablek et zouzzz, 

Je vais aussi ressortir mes consoles demain. Je ne sais plus si j'en encore unr avec une Viper, mais j'ai une Qoob Pro dans une d'elles, ça c'est certain. Il faut aussi que je retrouve mon adaptateur SD, mais au pire mon fer à souder peut résoudre le problème :P

Partager ce message


Lien vers message
Partager sur d'autres sites

sujet tres intéressant, je suis ca de prés.

j'ai aussi une GC avec une viper d'installé que je vais ressortir du carton afin de tester tout ca.

tu le chopes ou le dol special viper zouzzz ?

 

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut Hack, salut Shakin,

@Hack : le DOL spécial Viper est le dossier DOL de la r431 en téléchargement ici  : https://github.com/emukidid/swiss-gc/releases, il se nomme swiss_r431-lz-viper.dol.

 

 

N'arrivant pas à dormir cette nuit, j'ai un peu retravaillé sur mon problème.

3 tests indépendants les uns des autres : 

1ier test :  "Par hasard" j'ai tenté Swiss version Viper avec un autre jeu : Luigi Mansion. Résultat : il boote direct le coquin. Hmm-hmm

2ième test : De retour sur MKDD, je (re)contrôle le CRC-32, MD5 et le SHA-1 sur http://redump.org/disc/851/. Ils sont bien ok.

crc.png

Je retente de le booter : BLACK SCREEN.

3ième test : J'ai installé SDLOADab sur la Viper. Lorsque je le lance (boote avec appui sur A rapide), la SD card n'est pas reconnue, la liste reste vierge.

 

Partager ce message


Lien vers message
Partager sur d'autres sites

tu n'as pas touché aux options vidéo sur swiss ?

le black screen me rappelle quand un jeu demande confirmation pour démarrer en mode progressif (480p). Sauf que chez nous autres pauvres petits européens, Nintendo n'a pas cru bon nous autoriser à jouer en 480p...

Partager ce message


Lien vers message
Partager sur d'autres sites

Je ne savais pas qu"il y avait des différences entres versions de NGC. Il y en a d'autres ?

 

C'est bien possible que j'ai pu toucher des trucs qu'il ne fallait pas dans les options. Cependant j'ai regardé et rien n'est "forcé" dans les options vidéo.

J'ai tenté une nouvelle carte SD  "sait-on jamais" (celle de la 3DS de ma fille) : Mario Kart DD se lance ! Les intros saccadent (son et images) mais le jeu reste fonctionnel.

J'ai un peu honte de ne pas avoir tenter de changer de carte avant. :(

Merci pour vos aides.

 

 

edit :

"La Gamecube, dans sa version européenne, permet à certains jeux d'activer l'option 60 Hz, qui permet d'avoir une image plus nette et moins clignotante. La plupart des jeux qui n'ont pas cette option activable ont très souvent un mode 50 Hz optimisé. Enfin les versions japonaises et américaines, permettent, sur une sélection de titres, d'activer le mode progressif (Progressive Scan, 480p) afin d'avoir une image encore meilleure, à condition d'utiliser un câble adapté. Bien qu'on puisse brancher un tel câble sur les gamecubes européennes, l'activation du 480p en est impossible." https://fr.wikipedia.org/wiki/GameCube

Il faut que je me trouve une jap ou ou us DOL-001 moi.:)

 

 

 

Modifié par zouzzz

Partager ce message


Lien vers message
Partager sur d'autres sites

oui, les européens devaient être vu comme des retardés technologiques à l'époque...pas de 480p pour nous.

par contre avec une puce et/ou swiss, rien ne t'empêche de lancer des backups US, qui peuvent profiter du 480p même sur console européenne. Ce sont les jeux qui étaient incompatibles dans leur version euro, pas la console ;) 

 

je n'avais pas pensé à l'incompatibilité avec la carte SD, effectivement. C'est pourtant noté en clair en haut du wiki de liste de compatibilité de swiss-gc !

Partager ce message


Lien vers message
Partager sur d'autres sites

J'ai vu qu'il y avait une option SMB, c'est pour lancer ses backups/HB depuis un serveur ?

Partager ce message


Lien vers message
Partager sur d'autres sites

c'est bien ça, pour peu d'avoir bien sûr l'adaptateur ethernet

Partager ce message


Lien vers message
Partager sur d'autres sites

J'ai essayé mais ça me fait une zouzzz : black screen ! Que ça soit sur SD ou SMB.

Mais si ça tourne en half duplex, ça risque de ne pas suffire et faire comme à l'époque avec Phoenix Loader et la clique.

En tout cas, ça fait plaisir de voir que la scène a continuer son morceau de chemin.

 

Partager ce message


Lien vers message
Partager sur d'autres sites

de toute façon, du backup par SMB, à part pour le fun de le faire, je ne vois pas vraiment l'utilité.

pour un développeur qui veut injecter du homebrew facilement, pourquoi pas. Mais pour une utilisation "normale", c'est vraiment se donner de la peine pour que dalle :D
En tout cas j'aurais eu un adaptateur ehternet, j'aurais tenté pour m'amuser :P

Partager ce message


Lien vers message
Partager sur d'autres sites

Je viens de voir que Warp Pipe s'installait sur les derniers Windows.

Il y a plus de dix ans ça fonctionnait mais ça ramait vraiment beaucoup.

Dans le but de faire des parties en LAN sur MKDD à 8 avec des potes en fin d'année 2018, j vais prochainement (dans 2/3 semaines) recevoir deux BBA.

Ca dirait à quelqu'un de tester Warp Pipe ? Voir ce que ça donne en 2018 avec nos connexions un peu plus puissantes qu'il y a 15 ans.

 

 

Je n'ai pas la fibre, mon débit est d'environ :

3Mbps descendant 

0.5 Mbps ascendant

 

EDIT : je pense que c'est toujours injouable. :/ :

 

Modifié par zouzzz

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant