Southtown

Problème Jtag Usb Xénon

Messages recommandés

Bojour à tous,

J'ai monté un module Nbz sur ma console mais je n'arrive pas à lire ma nand...

Nandpro me renvoi "could not detect a flash controller" et gxnand me trouve bien le module mais me renvoi "Flash Config: 0x00000000" et "Nand Unknow Can not continue" !!

J'ai testé mon montage et je trouve une résistance entre j2b1.5 et la masse (env. 11k).

Si quelqu'un pouvait me venir en aide... ;)

Merci et @+

Partager ce message


Lien vers message
Partager sur d'autres sites

Ta console est bien branché quand tu essais de dumper la nand ? Tu as une photo de ton montage ?

Partager ce message


Lien vers message
Partager sur d'autres sites

mauvaise connexion ou inversion :whistling: souvent le cas quand on passe par des connecteurs entre le port et le module , le plus sur est liaison direct filaire cm/module

ou comme annoté inversion liaison ou mauvaise masse et comme annoté la console doit etre branché , Mais en mode vieille sinon pas de detection de la nand

Modifié par bugess

Partager ce message


Lien vers message
Partager sur d'autres sites

Comme le dit Bugess le mieux est d'éliminer le plus de cause de probleme donc aucun connecteur entre module et cm que du filaire.

Partager ce message


Lien vers message
Partager sur d'autres sites

Merci à vous deux pour vos réponses!

Mes essais ont bien étés faits console "alimentée" et mon montage est bien en filaire de la cm au module...

Par contre, la résistance que je trouve est entre les point j2b1.5 et j2b1.12, en ayant dessoudé les fils entre la cm et le module (les points de la cm sont "libres").

Pensez-vous que cette masse puisse venir de mon montage jtag?

Partager ce message


Lien vers message
Partager sur d'autres sites

Hello,

le souci "couldn't detect flash controler" vient souvent de l'un de ces 3 problèmes:

- mauvais montage

- mauvaise charge d'alim (ça arrive souvent), il faut tous débrancher (usb et alim) et changer l'ordre de branchement (l'usb en 1er, puis l'alim) si ça ne va pas, faire l'inverse.

- le module est connecté via un port usb partagé (ou hub), dans ce cas en prendre en direct sur la carte mère à l'arrière du PC.

++

Partager ce message


Lien vers message
Partager sur d'autres sites

Ok, je vais mettre des photos dès que j'aurai ressoudé mes fils vers j2b1.5 et j2b1.12.

Personne ne trouve bizarre la résistance mesurée entre ces 2 points sur la cm?

Juste pour être sûr d'avoir bien compris, je n'ai pas besoin du montage jtag pour lire ma nand? Exact?

Modifié par Southtown

Partager ce message


Lien vers message
Partager sur d'autres sites

Exact tu n as aucunement besoin du montage jtag pour dumper.

Partager ce message


Lien vers message
Partager sur d'autres sites

Les choses avancent mais plus que bizarrement...

Après avoir refait mes soudures plusieurs fois, j'ai toujours les mêmes erreurs mais j'ai quand même réussi à lire une partie de ma nand.

Voilà ce que j'ai du faire:

- une fois le module et le 220v branchés

- lancer gxnand --> Looking for Usb-Spi Module, Usb-Spi Module found ok, open usb, Flash Config: 0x00000000, Nand Unknow Can not continue

- lancer nandpro --> incompatible arm hardware for this version of nandpro

- Fermer la fenêtre gxnand

- lancer nandpro --> la lecture de la nand commence avec une erreur à chaque bloc

- Débrancher le 220v de la console --> la lecture continue avec une erreur à chaque bloc

- Rebrancher le 220v de la console --> la lecture continue sans les erreurs !!!

Comme conseillé, j'ai interverti les branchements, usb puis 220v et 220v puis usb mais les résultats sont les mêmes.

J'ai fait un relevé des tensions aux différents points du module:

Module alimenté par le port usb:

J1D2.1 -> 4.97V

J1D2.2 -> 4.97V

J1D2.3 -> 4.97V

J1D2.4 -> 0V

J2B1.5 -> 0V

J2B1.6 -> 4.35V

Module alimenté par le port usb et console reliée au 220V:

J1D2.1 -> 4.97V

J1D2.2 -> 4.97V

J1D2.3 -> 4.97V

J1D2.4 -> 0V

J2B1.5 -> 3.02V

J2B1.6 -> 4.31V

Module non alimenté et console reliée au 220V:

J1D2.1 -> 0.18V

J1D2.2 -> 2.28V

J1D2.3 -> 1.63V

J1D2.4 -> 0V

J2B1.5 -> 3.02V

J2B1.6 -> 0V

J'ai donc un gros doute sur le fonctionnement de mon alim 220V, j'espère que l'un de vous pourra m'aiguiller!

Partager ce message


Lien vers message
Partager sur d'autres sites

rien a voir avec l'alime , mais pour te convaincre , boot ta console si elle demarre , c'est que ta alime est bonne , autre methode de dump sans l'alime 360 , tu relies le port usb arriere a un port usb de ton pc , et tu retests le dump , mais a coup sur c'est un probleme de liaison

Modifié par bugess

Partager ce message


Lien vers message
Partager sur d'autres sites

Photo du montage ca serait un peu mieux

Partager ce message


Lien vers message
Partager sur d'autres sites

on va recommencer les essais

deja fait un test avec un soft comme Gx-Nand ou NandFlasher360 voir FlashInfectus , qui te donneront au depart l'etat de connexion du module , puis la detection de la nand

et au passage , branche le fil de masse du module a la carcasse du connecteur du DD ou sur un gros point masse du Pcb , par exemple sur la partie cuivrée nue autour d'un trou de passage de vis

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut et merci pour ton aide!

Toujours impossible de lire ma nand, avec nandflasher mon module usb est reconnu mais j'ai "erreur: nand non detecté" et avec gx_nand j'ai :

31/05/2011 19:50:20:843 Looking for Usb-Spi Module

31/05/2011 19:50:20:843 Usb-Spi Module found ok

31/05/2011 19:50:20:843 open usb

31/05/2011 19:50:21:562 Flash Config: 0x00000000

31/05/2011 19:50:21:578 Nand Unknow Can not continue

Comme tu me l'a conseillé, j'ai déplacé la masse du module sur un des points en cuivre.

Je commence à désespérer...

Partager ce message


Lien vers message
Partager sur d'autres sites

ta nand est pas detecté , donc defaut liaison ou bloquage nand , reverifie bien tes liaisons , a moins que ton module soit defaillant , un essai sur un autre pcb pour voir , sinon passe moi un mp si tu continues a galerer

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant