Starcom

[tuto] Récupérer Les Sauvegardes De Ses Originaux Avec Un Linker Slot

Messages recommandés

MERCI BEAUCOUPS ^^ ,

Enfin j'ai ma sav des pokemons sur mon linker ^^

Partager ce message


Lien vers message
Partager sur d'autres sites

Ary: Oui c'est bien l'adresse IP du PC

Alwin: Pas bête, je doute que ça résolve les problèmes de tout le monde, mais au moins ça montre la démarche. Je vais voir si c'est faisable.

Elou: De rien ^^

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut, (enfin bonsoir vu l'heure ^^ )

J'ai suivi le tutorial, mais ça ne marchais pas. J'ai donc lu le sujet pour essayer de trouver ce qui n'allais pas, premièrement j'avais pas enlever le .txt a la fin de savsender.conf, ensuite oublié d'ouvrir un port, ... Mais même en modifiant tout, pas moyen ça ne fonctionne toujours pas :S

J'aimerai donc savoir quel adresse IP rentrer exactement et où ^^ Donc si tu as le temps et l'envie de m'aider, voila un screen de la commande ipconfig/all (j'utilise la clé wifi nintendo) :

my.php?image=ipconfigyu2.jpgipconfig

Merci d'avance :D

Modifié par Kanna

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjour,

pareil, problème de connexion du savesender.

J'ai la bonne IP et la bonne clef wep sur ma DS (mario kart DS fonctionne), mais beup ne fonctionnne pas non plus.

Je lance savereceiver qui est alors en écoute de port, savesender est lancé, "Welcome to savsender 1.1!", et après au bout d'un certains temps ça plante ""could not connecto to AP ! Aborting"".

Je suis sous vista, j'ai désactivé le firewall, redirigé le port 33981 de mon routeur vers mon PC, l'IP dans le .conf est bien celle de mon PC, ainsi que dans savereceiver, j'ai bien le data/settings sur le linker.

Une question, cela fonctionne t'il sous vista ???

merci pour tout

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjour à tous,

Merci pour le travail remarquable que vous avez fait.

Le programme marche impeccable mais j'ai galéré pendant plusieurs jours avant de comprendre ce qui n'allait pas.

je tiens a faire partager mon expérience aux autres pour que ça les aide aussi.

La seule chose qu'on peut reprocher dans le tutorial c'est qu'en fait vous avez tellement l'habitude de votre façon de faire que vous oublié parfois d'expliquer des choses simple.

en fait j'avais tout paramétré et ça ne fonctionnais toujours pas. toujours ce message cannot connect to ap , aborting.

En fait c'est tout con mais vous n'avez pas insister sur le fait que pour que sa marche il faut deja avoir utilisé un jeu sur la ds qui nécessite de configurer la connection wifi et de la sauvegarder. Vous avez brievement présenté Mario Kart comme necessaire pour récupérer l'adresse mac en oubliant que beaucoup de newbie (moi le premier) ne savait pas que la console n'est pas magique. Tant qu'on ne l'a pas déja paramétrer pour une connection Wifi avec les parametres propre a chacun, aucun des soft disponible sur le net ne peut fonctionner.

J'ai récuperer toutes les sauvegardes de mon fils et je remercie Starcom pour son travail.

Ps moi j'avais pas Mario kart j'ai utilisé Pokemon diamant :ok:

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjour à tous.

Tout d'abord, merci pour ce tuto clair et facile à comprendre. Cependant, je rencontre un probleme :

J'arrive parfaitement à executer les manipulations du tuto, mais certaines infos ne correspondent pas avec ce que je constate sur mon materiel; je m'explique :

Je possède une ds lite ainsi qu'un m3 ds real tout récemment acquis.

J'ai donc tenté de suivre ce tuto afin de récupérer ma sauvegarde de new super mario bros.

Seulement, lorsque je lance savreceiver sur mon pc, au moment de choisir l'emplacement, je choisi M3 ds real comme type de linker et celui-ci lui donne une extension en .0 que mon linker ne semble pas reconnaitre (lorsque je lance le jeu, le message "no save file file found..." apparait). Et en effet, lorsque je regarde sur ma sd, toute les sauvegardes de jeux portes l'extension .sav.

Dans le doute, j'ai essayé de choisir chacun des autres formats proposés, nottement ceux utilisant les .sav, mais dans ce cas, le jeu trouve bien un fichier de sauvegarde mais celui-ci semble vide (ou en tout cas neuve : mes parties de mario sont absentes, tous comme les records aux mini jeux).

Après quelques recherches sur le net, j'ai trouvé un site qui permettait de convertir les fichiers de sauvegardes d'un format vers un autre; Cette fois-ci, c'est l'extension .dat qui m'a été imposé pour les m3 ds real et cette extension n'est pas non plus détéctée par mon linker. J'ai éssayé sans trop y croire différentes conversions vers des formats utilisant l'extension .sav mais me retrouve systématiquement avec un fichier de sauvegarde détécté mais vide (ou dont le contenu n'est pas le bon pour mon linker peut-etre).

Je précise également à toutes fins utile que j'utilise le logiciel via wine sous Ubuntu 8.10 ; Le transfert semble se dérouler sans pb, donc je ne pense pas que cela soit la cause de mes soucis mais sait-on jamais.

Apres trois jours de recherches sur le net, je suis à court de solutions à tenter donc toutes vos suggestions seront les bienvenues ;)

Merci d'avoir pris le temp de me lire, désolé si la réponse se trouvait quelque part (si t'a pas trouvé, t'a du mal cherché...) , j'accepte donc les rtfm avec le petit lien qui va bien si mon souci est déja évoqué quelque part ;)

Modifié par redisded

Partager ce message


Lien vers message
Partager sur d'autres sites

Salut à tous,

Je viens de recevoir ma supercard DS onei pour aller avec ma nouvelle DSi. Comme j'aimerais jouer uniquement à partir du linker, je souhaite rapatrier ma sauvegarde du jeu original castlevania sur celui-ci. Hélas, malgré votre tuto, je suis lamentablement bloqué comme un novice que je suis. J'ai testé les deux solutions proposées (c'est-à-dire wifi back-up tools ainsi que savesender) sans résultat. À chaque fois je reste bloqué à la première étape de connexion.

Si ça peut vous aider, voici grosso modo ma config : - freebox v5 en mode routeur

- pc connecté en réseau par wifi

- mon ssid n'est pas masqué

- réseau crypté en WPA (TKIP + AES)

Pourriez-vous m'aider à configurer mon réseau s'il vous plaît ? Merci d'avance.

Partager ce message


Lien vers message
Partager sur d'autres sites

salut a tous

j'ai petit souci

j'ai bien suivi le tuto qui et très claire

mais j'ai un message d'erreur sur savsender 1.1

j'ai une r4 sdhc

mon message d'erreur sur la ds

Welcome to savsender1.1!

connected to ap

opening config file ...

Error opening config file!

voila j'ai bien mis sur ma carte un dossier nommé DATA et dedans un autre nommé SETTINGS dedans l'ip de mon pc avec le port en le nomment savsender.conf

puis-je avoir votre avis sur sa si j'ai bien fais les chose

pourriez-m'aider svp

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonsoir,

J'ai la clé USB wi-fi nintendo et je suis connecté à internet par câble!

Comment faire fonctionner savsender et savreceiver?j'ai bien mis l'adresse ip de ma clé usb 172.16.0.1 et mon port 33981 dans savreceiver et dans savsender.conf mais ça me met sur ma DS "Could not connect to AP!Aborting."

Je pige pas :|

Partager ce message


Lien vers message
Partager sur d'autres sites

Bonjour à tous.

Bon ce post a été commencé indirectement sur un autre topic (ici) mais comme cela concerne SavReceiver je le poste ici ;) .

Résumé de l'épisode précédent :D :

[...] au passage personnellement je ne cherche pas à faire une copie du jeu mais plutôt de récupérer une save de mon jeu original pour le transférer sur le linker. J'ai testé la méthode avec SAVSENDER/SAVRECEIVER tout se passe bien mais le fichier récupéré de la cartouche n'est pas reconnu par la rom (FinalFantasy III). En fait il me l'écrase au lancement de la rom pour me créer un nouveau fichier de sauvegarde vide. J'ai testé avec les deux systèmes que permet SAVSENDER/SAVRECEIVER (à savoir "M3 Simply / R4" et "DS Link") et dans les deux cas c'est la même chose (mis à part que le fichier généré par M3 Simply fait 512ko (ce qui correspond à la taille des seaves présentes sur mon linker actuellement) et le fichier généré par DS Link ne fait que 256ko.

Donc pour préciser mon problème voici un screenshot de ce que me met la DS (DSi pour plus de précisions) :

1258914742313330.jpg

Donc apparemment tout se passe super bien, le fichier .sav est bien créé sur mon PC sauf que dès que je le fait passer sur le linker il se passe ce que j'ai expliqué plus haut. De plus j'ai testé d'ouvrir un vrai fichier .sav de final fantasy avec notepad++ (ce qui donne un résultat assez illisible avec des caractères spéciaux partout) alors que si je fait de même avec le fichier généré par SavReceiver il ne m'affiche que des symboles "NULL". En images ça donne ça :

1258915036313330.jpg

Fichier .sav créé en lançant le jeu directement sur le linker et donc bel et bien reconnu

1258915094313330.jpg

Fichier généré par le programme SavReceiver et qui n'est pas reconnu par le linker

Donc on voit clairement ici qu'il y a un petit soucis et que les deux fichiers ne se ressemblent pas du tout (bon ça ça doit être normal car il ne s'agit pas exactement de la même sauvegarde) mais surtout que dans le fichier généré par SavReceiver il n'y a que des NULL (même en scrollant horizontalement) ce qui à mon avis n'est pas normal...

J'ai également testé avec le "patch" de starcom permettant d'ajouter plus de linkers à la liste. Mais même résultat avec tout les modes de la liste :( .

Donc si quelqu'un avait une idée ça serait vraiment cool de se signaler :P .

Merci beaucoup de m'avoir lu.

Amicalement,

alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites

La taille de la sauvegarde faite par ton linker est aussi 256 ko, comme le DS Link, non ?

Ce qui serait pas mal c'est que tu joignes tes deux fichiers et si possible une sav d'un autre jeux.

Quels résultats avais tu avec Backup tool ? si tu as reçu un fichier, joints-le aussi.

Merci.

Partager ce message


Lien vers message
Partager sur d'autres sites
le fichier généré par M3 Simply fait 512ko (ce qui correspond à la taille des seaves présentes sur mon linker actuellement)

Non comme j'ai dit là les fichiers .sav générés par mon linker font 512ko ;) .

Voilà l'adresse de là où j'ai mis les sauvegardes (car sur le forum je ne peux pas uploader des fichiers de plus de 300ko :S : http://www.mediafire.com/?sharekey=42ec405...f116cccf9018c5f

En fait je pense que la communication se fait correctement mais que les données ne sont pas transmises (d'où les NULL dans le fichier reçu...).

Voilà j'espère vraiment que tu pourras m'aider.

Amicalement,

alpha12

[Edit] : Avec Backup Tool je ne reçoit rien en fait la homebrew ne me détecte même pas le jeu original :S .

Modifié par alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites

En fait tu ne reçois rien. C'est pour ça que ton fichier ne contient que des "Null".

J'en doute un peu mais c'est peut-être une protection ou une nouvelle structure de la carte de jeu. Est-ce que ça fait pareil avec un autre jeu ?

Peut-être que ton wifi homebrew délire. As-tu essayé avec succès d'autres homebrew wifi comme dsorganize ou dsftp ?

La bonne nouvelle c'est que, pour l'instant en tout cas, c'est pas un problème de format.

Tu peux aussi essayer avec la dernière version de BackupTool:

http://mobiles.gx-mod.com/modules/news/art...hp?storyid=9068

Partager ce message


Lien vers message
Partager sur d'autres sites
En fait tu ne reçois rien. C'est pour ça que ton fichier ne contient que des "Null".

C'est bien ce que je pensais...

J'en doute un peu mais c'est peut-être une protection ou une nouvelle structure de la carte de jeu. Est-ce que ça fait pareil avec un autre jeu ?

Oui lors de mes premières tentatives j'avais testé avec tout mes autres jeux originaux (plus d'une dizaine...) mais même résultat...

Peut-être que ton wifi homebrew délire. As-tu essayé avec succès d'autres homebrew wifi comme dsorganize ou dsftp ?

Non pas du tout j'avoue même ne jamais avoir installé d'autres Homebrew que SavReceiver. Je vais aller tester celles que tu m'a signalé dès que j'ai un peu de temps.

La bonne nouvelle c'est que, pour l'instant en tout cas, c'est pas un problème de format.

Cool c'est au moins ça de pris :P .

Tu peux aussi essayer avec la dernière version de BackupTool:

http://mobiles.gx-mod.com/modules/news/art...hp?storyid=9068

Idem que plus haut dès que j'ai un peu de temps je teste ça.

Bon voilà je ferais ces tests probablement demain ou après-demain (car en début de semaine là j'ai un peu de boulot).

Dès que j'ai du nouveau je reviens poster ici pour vous tenir au courant.

Et encore merci à toi Starcom pour l'attention que tu portes à mon problème ;) .

Bonne soirée à tous !

Amicalement,

alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites

No problemo ;).

Pour ma part, je passerais p'têtre plutôt demain soir, donc t'inquiète pas si je ne répond pas du tac au tac.

Sur ce coup là, tu as eu du bol. Je passais en coup de vent sur le forum.

Ouais donc le premier truc à voir c'est trouver où se situe concrètement le problème en évitant le plus possible les suppositions et les à priori.

Donc je suis quasiment certain que ta DS se connecte bien. Sinon tu aurais le message "Couldn't connect to the AP".

Il faudrait voir au niveau des IP, du routage et du Pare-feu. Ton réseau wifi est architecturé comment ? Une box, un routeur ?

Partager ce message


Lien vers message
Partager sur d'autres sites

Je passe juste en coup de vent pendant ma pose pour répondre à ta dernière question.

Voilà ma config :

DS -> Wifi -> DartyBox (pas de Troll s'il vous plait surtout que leurs services sont impeccables depuis plus de 2ans que je l'ai) -> Wifi -> PC

Pour ce qui est de la config du routeur : pare-feu activé, port 33981 (celui que j'ai mis dans la config de SavReceiver) forwardé vers l'ip du PC.

Donc ce soir dès que j'ai 2 minutes premier test que je fait c'est désactiver le pare-feu, mettre le PC en ethernet sur la box et essayer de relancer SavReceiver.

Mais je maintiens que je trouve ça assez étrange que la DS se connecte sans soucis au PC mais que les données ne soient pas transmises. ^^

Allez à ce soir ++,

alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites

Petit post en passant: J'avais pas vu qu'il y avait autant de requêtes concernant des problèmes ici. Je vais faire une réponse à tous, même à ceux de 2008.

A première vue, je dirais déjà que redisded a le même problème qu'alpha12.

Sinon, le plus ancien déjà: Kanna -> Change l'adresse IP de ton PC en 192.168.1.238, re-forward le port vers cette IP et modifie le fichier savsender.conf avec cette IP.

Pour alpha12: J'attends de tes news.

Pour les autres, patience, je m'occupe de vous ;)

_______________________________________________

Edit: Et me revoilà !!!

... - réseau crypté en WPA (TKIP + AES)

Pourriez-vous m'aider à configurer mon réseau s'il vous plaît ? Merci d'avance.

Essaye en ne cryptant pas ton réseau.

...Error opening config file!

Comme le dit le message, il y a une erreur d'ouverture du fichier. Soit il n'est pas à la bonne place, soit il n'a pas le bon nom. Vérifies bien son orthographe et qu'il n'ait pas d'extension .txt masquée (donc l'icone doit être autre chose qu'un bloc note)

... j'ai bien mis l'adresse ip de ma clé usb 172.16.0.1 et mon port 33981 dans savreceiver et dans savsender.conf mais ça me met sur ma DS "Could not connect to AP!Aborting."

Je pige pas :|

C'est un problème réseau. Vérifie le pare-feu, le forward du port 33981, et que la plage d'adresse de la DS et du PC soit la même.

Essaye un homebrew réseau DS (navigateur de DS Organize par exemple) pour voir si ton réseau est OK.

Ouf!! Ca c'est fait. :D

Partager ce message


Lien vers message
Partager sur d'autres sites

Bon moi je viens aux nouvelles !

J'ai donc testé de désactiver le firewall de la box, du PC, de brancher le PC en ethernet, d'activer la DMZ sur mon IP tout ça en même temps et en laissant le port 33981 forwardé vers la nouvelle IP de mon PC (puisque je suis passé de wifi à ethernet).

Et strictement même résultat qu'avant un fichier rempli de "NULL" sur une seule ligne...

Peut-être que ça vient du fait que j'exécute la homebrew sur une DSi et que le système de communication wifi de la DSi n'est pas le même que celui des DS/DSlite...

Ce WE je vais récupérer une DS "tank" pour voir si ça me fait pareil.

Dans tout les cas si quelqu'un a une idée je suis preneur...

Amicalement,

alpha1

[Edit] : J'ai également testé avec NDS_Backup_Tool et la nouvelle version me met "DSi hardware does not work" lol...

Modifié par alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites
...Ce WE je vais récupérer une DS "tank" pour voir si ça me fait pareil...
Alors ??

Partager ce message


Lien vers message
Partager sur d'autres sites

Pas pu la récupérer ma soeur (propriétaire de la DS) et mes parents étaient partis en week-end :( .

Ça sera pour la prochaine fois que je passe les voir.

Quoi qu'il en soit je vous tiens au jus si j'ai du nouveau.

Partager ce message


Lien vers message
Partager sur d'autres sites

Alors concernant le problème de alpha12 j'ai exactement les mêmes symptômes pour le jeu : "Professeur Layton et l'Etrange Village". (rom 2888)

J'ai le jeu original avec une sauvegarde que je voudrais récupérer pour ensuite la mettre sur mon linker.

J'ai mis la rom du jeu sur le linker. Le jeu fonctionne parfaitement.

En revanche, impossible de mettre la sauvegarde original du jeu sur le linker.

J'ai fait exactement ce qui a été dit avec tout les utilitaires disponibles :

J'ai un linker DSOnei à jour.

La communication Wifi et FTP entre la DSi et le PC fonctionne correctement.

 - savesender + savereceiver --> Obtention de fichiers vides (quelque soit la taille de l'EEPROM)

 - savesender + netcat         --> Obtention de fichiers de 8 Ko vides. Même après la conversion avec "Savegame Conversion website" http://www.shunyweb.info/convert.php?id=22962057 : le fichier est illisible)

 - NDS Backup Tool Wifi        --> the card of slot-1 cannot be recognized

Edit : J'ai une Nintendo DSi FW 1.4E

Help please!  

Modifié par Realistic

Partager ce message


Lien vers message
Partager sur d'autres sites

En voyant ce que tu dit j'aurais tendance à penser que ça vient de la DSi :S puisque le seul point commun entre nous est le modèle de la console...

Pour ma part je n'ai toujours pas remis la main sur une DS qui ne soit pas DSi mais dès que c'est le cas et que j'ai l'occasion de tester avec une autre DS je reviens vous voir avec les résultats obtenus.

@+

Amicalement,

alpha12

Modifié par alpha12

Partager ce message


Lien vers message
Partager sur d'autres sites

 

 

Ok merci alpha12.

Je continu les recherches de mon côté mais j'avouerai que je commence un peu à fatiguer :P

 

Partager ce message


Lien vers message
Partager sur d'autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant